Fedora 40 KDE Discover 6.0.5 freeze

Hi there,

I returned to Linux after many years and out of the several distros I have trialled, I feel most at home with Fedora 40 KDE Spin. I have always had a preference for the customisation capabilities of KDE and it just feels like home with it.

It was a clean install and everything went fine for about a month and I have configured it just the way I like and installed many of the software I need. I have added snap, FlatHub and a few other repos like the RPM Fusion free and non-free ones.

However, since the last few days, it has been freezing all the time. It takes about 30 seconds to start. Search is the worst. On searching for any package, it takes a few minutes to respond (if it does at all) and every single click since then freezes it even more. I have tried disabling all the repos, which did not make any difference either. I had installed some packages (like Hardware Probe and ProjectLibre) which needed older Qt/KDE versions which I have also removed, but still the issue persists.

When it becomes non-responsive, it turns into monochrome with a “(Not responding)” message shown on the title bar next to the window title. It takes minutes (no exaggeration) for it to respond.

It is not a broadband issue, as I am connected to fibre-optic broadband. There is no VPN configured. Though I have Portmaster running, there are no blocks in or out for Discover. I have also tried with Portmaster turned off, no change.

There are no issues or slowness with other apps.

Can someone point me to how to troubleshoot the issue or reset Discover please?

Many thanks in advance.

Rupak

System:
Acer Swift SF314-42 | AMD Ryzen 5 4500U, 8 GB RAM, 1 TB SSD
Fedora 40 KDE Spin
KDE Plasma / Discover 6.0.5
KDE Frameworks 6.3.0
Qt version: 6.7.1
Kernel version: 6.8.11-300.fc40.x86_64 (64-bit)
Graphics Platform: Wayland

This is the indication in Plasma that the application is frozen and won’t respond to system messages. If could be that Discover is blocked on some PackageKit operation.

This is likely not a Discover issue (though one may legitimately expect Discover to not run potentially blocking operations on the UI thread) but a problem with the Fedora PackageKit integration.

Can you please run the following troubleshooting command in a terminal:

pkcon search SOME-APPLICATION

and check how long it takes to return a response. On my system it takes under 2 seconds.

Hi Oded,

Thank you for your reply.

It was almost instantaneous to run the command - took 1 second.

rupak@fedora:~$ date ; pkcon search discover ; date
Sun 16 Jun 13:42:51 BST 2024
Searching by details                    [=========================]         
Starting                                [=========================]         
Finished                                [=========================]         

.... 230+ entries

Sun 16 Jun 13:42:52 BST 2024
rupak@fedora:~$

Cheers,
Rupak

And at the same time you can see discover frozen?

Yes, Discover is sitting frozen in the background as I ran this command again.

It would probably be useful to debug this problem if you can close discover (and make sure it is killed if it is frozen) then run it again to reproduce the frozen behavior, finally run this command in terminal:

journalctl --user SYSLOG_IDENTIFIER=plasma-discover -S -5m > discover.log

Then upload the resulting discover.log file somewhere (Unfortunately discourse will not let you attach arbitrary files).

Thanks again Oded, very much appreciated.

I followed your instructions and got the log.

I am unable to include links in my posts.
You can find the file at:
file[dot]io[slash]QMp96iXwgcAO

Cheers,
Rupak

I was not familiar with file.io and it looked like a cool service - except that it only allows files to be retained for a single download - which mean that after I looked at the file, no other developer could, which isn’t great for this kind of discussion :frowning: .

Fortunately, the content isn’t long and can be pasted here:

Jun 16 14:05:26 fedora plasma-discover[11534]: org.kde.plasma.libdiscover: OdrsReviewsBackend: Fetch ratings: false
Jun 16 14:05:26 fedora plasma-discover[11534]: adding empty sources model QStandardItemModel(0x5615b7963100)
Jun 16 14:05:27 fedora plasma-discover[11534]: qrc:/qt/qml/org/kde/discover/qml/DiscoverWindow.qml:330:5: QML OverlaySheet: Binding loop detected for property "implicitHeight"
Jun 16 14:05:27 fedora plasma-discover[11534]: qrc:/qt/qml/org/kde/discover/qml/BrowsingPage.qml:17:1: QML BrowsingPage: Created graphical object was not placed in the graphics scene.
Jun 16 14:05:46 fedora plasma-discover[11534]: qrc:/qt/qml/org/kde/discover/qml/ApplicationsListPage.qml:16:1: QML ApplicationsListPage: Created graphical object was not placed in the graphics scene.

I don’t see anything that is immediately obviously wrong here - I have expected a lot more out from looking at Discover running on my system.

I think the message Binding loop detected for property "implicitHeight" is a warning and does not actually causes an endless loop - I actually see this in my Discover logs, and on my system it works fine.

I think I have Plasma set to output debug level messages to the journal, but I’m not sure how it was set up like that. I’ll dig into it a bit more.

Oh, I didn’t know. This is the first time I used it. It was the first option in DuckDuckGo!

I very much appreciate your help looking into this. If there’s any other checks I can do, please let me know.

I’ll be away for the rest of the afternoon, will be back in the evening, so will check on any further messages then.

Many thanks,
Rupak