File Search Indexing Not Enabling

I disabled the indexing and now when I re-enable it I can’t get it to work. It says it is enabled, but no matter how long I go, and how many restarts I do, it says “Not Running, 0% complete.”

Is this a bug?

Open konsole and type

balooctl6 status

if you are on plasma 6. If you are on older plasma version type (I believe this is the right command)

balooctl status

and let us know what the output is.

1 Like

Baloo File Indexer is not running
Total files indexed: 1,791
Files waiting for content indexing: 1,454
Files failed to index: 0
Current size of index is 1.07 MiB

Well, apparently it has already indexed some files and there are more to be index. Could you please give it some time and run the same command some time later and see if the “Total files indexed” and “Files waiting for content indexing” has changed?

See also the following. It might provide you some additional troubleshooting suggestions

1 Like

Thank you. A while back my index file size was almost 1 GB before I deleted it and disabled indexing.

Also, now when I hit “Pause Indexer” noting happens. I’d think that button should be clickable and turn into “Resume Indexer” but it doesn’t work. It’s like how the system Restart button used to be before that bug was fixed. I’d push “Restart” and nothing would happen.

Are you on plasma 6 or on older version?

Seems like there might be a bug in plasma 6: in my case (I just checked) all files are indexed but when I click pause indexer and then resume it says 0% indexed and I’m pretty sure before pausing it, it was saying 100%, but I may jut be crazy :roll_eyes:

I’m really sorry I can’t help any further :frowning:

1 Like

Yes, I’m using the latest KDE 6. Your index is over 6 GB, which means you have a very good-sized index. In my case my current index is at only 1 MB. My disk has about 40 GB of used storage.

Does that make sense? I mean 1MB index size for 1791 files (which are supposedly indexed) seems too small. Are you indexing contents or filenames only?

In any case let’s wait to hear a second opinion from some one else.

1 Like

I’m trying to index my whole home/current-user folder. Default settings.

Maybe check whether the indexer has crashed…

You don’t say what distro you are running but you can try:

systemctl --user status kde-baloo

which would show you if it is “alive” as far as systemd knows. If it looks dead, you can try:

systemctl --user restart kde-baloo

and check the status again. You can also look at the processes independent of systemd with:

pgrep -a baloo_file

If it keeps on dying, have a look at the logs with journalctl. It’s also possible to enable debug logging so you see a little more. Post back if you want details.

It is possible but unlikely that it is hitting a file that “kills” it. It may also be that baloo is confused after the Plasma 6 upgrade.

1 Like

Thank you. It had crashed. I followed your command to restart it, and now it’s indexing.

Here’s what it said:

× kde-baloo.service - Baloo File Indexer Daemon
Loaded: loaded (/usr/lib/systemd/user/kde-baloo.service; enabled; vendor preset: enabled)
Active: failed (Result: signal) since Sat 2024-03-09 05:34:49 MST; 3h 59min ago
Process: 1032 ExecCondition=/usr/bin/kde-systemd-start-condition --condition baloofilerc:Basic Settings:Indexing-Enabled:true (cod>
Process: 1067 ExecStart=/usr/lib/x86_64-linux-gnu/libexec/kf6/baloo_file (code=killed, signal=ABRT)
Main PID: 1067 (code=killed, signal=ABRT)
CPU: 1.701s

Now it says my indexing is 100% complete and when I hit Pause Indexer it actually works. I’m then given the option to Resume it.

I will keep an eye on it to ensure it stays running properly in the days ahead.

I use KDE Neon 6.0 with all the latest updates. Initially I was using Wayland, but I switched to X11 because Wayland was not stable on my system. Wayland crashed frequently while X11 never does.

I noticed my file search indexing again on 0% and not running. I ran:

“systemctl --user status kde-baloo”

Errors as before, indicating baloo crashed.

I restarted it now using:

“systemctl --user restart kde-baloo”

Now it’s indexing.

Therefore, I hope some developers can look into this matter to get to the bottom of why this daemon keeps crashing.