Files missing in Dolphin

I have 2 types of file in 1 folder A: mkv and ass.
I was renaming 92 mkv files, and it was good.
Then, I renamed 92 ass files, and it proceeded with no error.
However, when I closed KRename and back to Dolphin, only 82 mkv and 82 ass left in the folder.
I checked the Thrash folder to ensure I did not accidentally press “Del”, and there was 0 file in Thrash.
I checked the file size of the folder, and indeed the total file size has changed - the files were not hidden, but totally missing/erased.
This is a strange phenomenon which I have not encountered before.
Any clue to perform troubleshoot?

Edit 1:
I performed the rename of the 92 ass files in another folder B, and the process completed successfully.
Now, when I moved the 92 ass files into the main folder A (with mkv), the 92 ass files became 82 ass again!

Edit 2:
I created a new folder C, and copied all 92 ass files into it, and process completed successfully.
All 92 files intact.
I moved the remaining 82 mkv files into this new folder, process completed successfully.
When I browsed back folder A, all 10 remaining missing mkv files, miraculously reappeared.
These 10 files were missing, and the file size check of the folder also confirmed its disappearance as file size of the folder has reduced accordingly.
I moved the “missing” mkv files into folder C, and checked the file size of all 92 mkv files, and it was correct.

So, what is exactly happening here?

This “file missing” problem, seems happening everywhere.
Had another instance involving another HDD, but also involved renaming files using KRename.

I had an issue with krename lately, too. When I selected multiple folders to rename/move (with subfolders) it kept crashing. If I added those folders separately, it worked without a hitch… Now, it works again.

I think it was something qt related, at least starting krename in console suggested so. Perhaps this can give you a pointer.

Other than that: Did you check ownership (files/folders)? Any funny symbols?

PS: Excuse my stupid questions but why ass instead of srt and why not embedding them into the mkv?

Ownership was an not issue - cuz I was the owner.

PS: the format downloaded is ass, then it is ass. I’m not fussy about its format.
Embedding into mkv, has its advantages. But if the subs is not translated well, I can always swap to another subs easily - since this is external subs.

1 Like

Well, if it does show always the same Uid… weird.

Any funny chars in the name? Does it happen as well if you mv them manually?

PS: Nice to see another subber :heart_eyes:

Funny chars?
Other than [] which are accepted in NTFS, nothing much.

So far, the “missing file” happens after KRename performed the job - and any file within same folder is at risk of becoming “missing”.
I’m not sure if the extent of “missing” happens to all other folders within the same HDD yet.

Had some PDFs once with german umlauts… Usually never had any problems with chars, german, russian, french, japanese but these particular files were just wrecking everything up (any copy/move ended with error).

After running detox over it, they complied with everything.

How do you know? You see them renamed and then vanishing? Since you mentioned NTFS, does happen on other FS (ext4), too?

Did you try mv yet?

I initiated KRename from Dolphin’s right click menu.
After rename, I closed KRename and back to Dolphin, and the files went missing.
Ext4 is ok though, no such issue yet.

Move? No issue.

Perhaps your renaming does something that is not possible on NTFS? Hard to tell without any example, btw.

To be on the same, I meant the command “mv” as a means to simulate your renaming…

And a dry run with detox revealed anything?

I came from Win environment, so I’m pretty sure my naming fits the requirements of NTFS.
Moreover, for KRename, if the naming doesn’t fit the FS used, the app would report an error and refuse to proceed.
What I know and certain now, is that the files only gone missing after KRename performed the task.
And when this happen, the relevant folder cannot be deleted in Dolphin nor Nemo.
In addition, Dolphin would become very prone to “no response”, and the processed had to be “killed” in order to close it and open a new one.
However, after reboot, the affected drive cannot be mounted due to “unknown error”.
Had to be fixed using command ntfsfix, and it is reported that “mftmirr does not match mft” error during the fix.

Just performed another rename using KRename.
And indeed, right after renaming, the Dolphin refreshed the list of files, and the files disappeared.
This is another HDD not involved with the previous file missing issue.
The FS is NTFS.

Well, I wouldn’t bet my life on it, especially considering this issue :crazy_face:

Alternatively, how about exFAT? Does it fail in the same way?

You did figure out what files are affected, didn’t you? Perhaps you can reveal your renaming (obscure any specific name)? I mean otherwise it’s really hard to help. I don’t even know if you use “normal” or regex…

And I still wonder what happens if you’d try to rename manually:

mv oldname newname

(You said “no issue” before but not sure if you meant the command above)

Never try exFAT.
My mkv files are rather large, and USB drive (which uses exFAT) wun fit.

[Sub1&Sub2] Name - EP [WebRip 1080p HEVC-10bit AAC ASS][CRC]

Typically my mkv files look like this.

However, after these few days of disaster, I can confirm the following:
a. The files disappear ONLY after KRename performs the operation, and the disappearance happens together with the renaming.
b. Only happened on NTFS, not Ext4.
c. Doesn’t matter if the rename uses regex or “normal”.
d. Doesn’t matter what special characters are used in destination file name.
e. The disappeared files, not showing up in Dolphin, and don’t seem to be occupying space according to Folder’s Properties. But the HDD available space is lesser, ie. files gone missing, but original space still occupied, and not emptied/recovered.

I dun use console for renaming batch files.
If single file, just F2 in Dolphin.
In fact, I primarily use KRename when renaming large quantity of files.

Screenshot 2023-06-23 at 20-21-12 exFAT - Wikipedia

krename can handle that but I hate brackets (they caused me always trouble with JMkvpropedit, just IMHO) :smiley:

I know, just wondered

a) if the error happens when doing it manually (with those problematic files) and
b) if it’s limited to krename

I mean how to reproduce this error elsewhere? I just tried it with your pattern on NTFS and it went through without a problem. For you it’s always the same files causing trouble, I assume?

Brackets would have issue in “standard” renaming, cuz it is being treated as regex, rather annoying.

a. There is no “problematic files”.
Any file can be “disappeared”, as long as the renaming involves KRename and NTFS.
If the rename does’t involve KRename (ie. manual rename), then there is no problem.

To reproduce: KRename + NTFS.
And let me reiterate: any file can experience the problem, NOT “always the same files causing trouble”.

My KRename is version 5.0.2.

Operating System: Manjaro Linux
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.106.0
Qt Version: 5.15.9
Kernel Version: 6.3.5-2-MANJARO (64-bit)
Graphics Platform: X11

Oh, with Bullseye I am somewhat behind:

KRename Version 5.0.1
Operating System: Debian GNU/Linux 11
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.0-23-amd64

Thanks for being explicit. Hmm, does it matter how many files krename has to handle when it breaks? (if so, I will try another run)

I dun believe number of files is a trigger.
I have tried 90 files on EXT4, and it was fine.
But the same 90 files on NTFS, 84 of them went missing.

And before this latest upgrade (to KRename v5.0.2), it was working fine.

So, I presume this latest version of KRename is the issue.
Though I am not sure if other KDE components also contributing to this issue.

But right now, I can only pinpoint to KRename + NTFS.

Holy! 84/90 is quite some number… had just 6 or 7 but that worked, will try some more tomorrow…

Tried simple batch rename in Dolphin (select multiple files, then “F2”), and that worked in NTFS.
So I guess the culprit is pretty narrowed down.

In another instance, the above F2 method, resulted in 8/88 files disappeared in Dolphin.