First impressions of plasma 6

I’m writing this about 5 mins into upgrading to plasma 6, and it is cute.
Wayland, no problem. That was what was mostly worrying me, but worked just fine.

My theme was missing though, so I was meat with an ugly a** looking SDDM, but that is because my distro did not port the theme to plasma 6 it seems.
So there are other small theme related errors, but that is not something I can blame on KDE.

Floating panels, cool, but I do not want them.
So editing them I found the first bug.
If I edit the panel at the bottom and change style to “non floating”, the panel iteslf sticks to the config window, dragging it up from the bottom of the screen.
Easily fixable with just moving it to the top and then back down again.
These are small bugs I suspect to find.

But over all, WELL DONE!


I am just curious: don’t you have any of these (small) bugs?

Please see A medley of (non-critical) bugs in Plasma 6 that I have encountered .

1 Like

Manjaro unstable, kinda arch stable I guess. xD
Side note: My arch installation failed mid installation yesterday, pacman not finding plasma-wayland-session.
My suspicion is I was doing the installation JUST as plasma 6 got pushed to stable. I think it got replaced with plasma-session or smthn, I saw it in the log when upgrading on manjaro.

System info

Kernel: 6.7.7-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.7-x86_64
root=UUID=700d034d-b99a-482b-880b-9060acf3a6b3 rw rootflags=subvol=@
modeset=1 fbdev=1 nvidia_drm.modeset=1
resume=UUID=5ae8fbf5-a704-41ea-be6d-bf26b38325ed udev.log_priority=3
Desktop: KDE Plasma v: 6.0.1 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Manjaro base: Arch Linux
Type: Desktop Mobo: Gigabyte model: X670 AORUS ELITE AX v: x.x
serial: uuid: UEFI: American
Megatrends LLC. v: F21 date: 01/10/2024
Info: model: AMD Ryzen 9 7900X bits: 64 type: MT MCP arch: Zen 4 gen: 5
level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
model-id: 0x61 (97) stepping: 2 microcode: 0xA601206
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 12 MiB desc: 12x1024 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 533 high: 3593 min/max: 400/5733 scaling:
driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
5: 400 6: 400 7: 400 8: 3593 9: 400 10: 400 11: 400 12: 400 13: 400 14: 400
15: 400 16: 400 17: 400 18: 400 19: 400 20: 400 21: 400 22: 400 23: 400
24: 400 bogomips: 225270
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: gather_data_sampling status: Not affected
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_rstack_overflow mitigation: Safe RET
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: driver: nvidia
v: 550.54.14 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
(as of 2024-02; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none empty: DP-1,
DP-2, DP-3, HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:2204 class-ID: 0300
Device-2: AMD Raphael vendor: Gigabyte driver: amdgpu v: kernel
arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
speed: 16 GT/s lanes: 16 ports: active: HDMI-A-2 empty: DP-4,DP-5,DP-6
bus-ID: 15:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 53.0 C
Display: wayland server: v: with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
gpu: nvidia,amdgpu display-ID: 0
Monitor-1: HDMI-A-2 res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
drv: nvidia device: 2 drv: radeonsi device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: radeonsi x11: drv: radeonsi
inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 24.0.2-manjaro1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
raphael_mendocino LLVM 16.0.6 DRM 3.57 6.7.7-1-MANJARO)
device-ID: 1002:164e memory: 500 MiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 9 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3090 driver: nvidia v: 550.54.14
device-ID: 10de:2204 surfaces: xcb,xlib,wayland
Device-1: NVIDIA GA102 High Definition Audio vendor:
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:1aef class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 15:00.1
chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 15:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.7.7-1-MANJARO status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: JACK v: 1.9.22 status: off tools: N/A
Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0e:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp14s0 state: up speed: 1000 Mbps duplex: full mac:
Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 0f:00.0
chip-ID: 14c3:0616 class-ID: 0280
IF: wlp15s0 state: down mac:
Info: services: NetworkManager, smbd, sshd, systemd-timesyncd,
Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:5 chip-ID: 0e8d:0616
class-ID: e001 serial:
Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: see --recommends
Local Storage: total: 4.09 TiB used: 2 TiB (48.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: fw-rev: 5B2QGXA7 temp: 46.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: fw-rev: 4B6Q scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD30EFRX-68EUZN0 size: 2.73 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial:
fw-rev: 0A80 scheme: GPT
ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 63.08 GiB (63.1%)
fs: btrfs dev: /dev/sda7 maj-min: 8:7
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 296 KiB (0.1%) fs: vfat dev: /dev/sda5 maj-min: 8:5
ID-3: /home raw-size: 250.8 GiB size: 250.8 GiB (100.00%)
used: 140.52 GiB (56.0%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%)
used: 63.08 GiB (63.1%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
compressor: zstd max-pool: 20%
ID-1: swap-1 type: partition size: 38 GiB used: 256 KiB (0.0%) priority: -2
dev: /dev/sda6 maj-min: 8:6
System Temperatures: cpu: 60.4 C mobo: 46.0 C gpu: amdgpu temp: 54.0 C
Fan Speeds (rpm): N/A
Memory: total: 32 GiB note: est. available: 30.5 GiB used: 7.8 GiB (25.6%)
Processes: 497 Power: uptime: 4h 15m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.15 GiB services: org_kde_powerdevil,upowerd
Init: systemd v: 255 default: graphical tool: systemctl
Packages: 1717 pm: pacman pkgs: 1706 libs: 449 tools: pamac,yay pm: flatpak
pkgs: 11 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 default: Bash
v: 5.2.26 running-in: yakuake inxi: 3.3.33

I don’t use widgets or floating panels so not those. But I did notice the overview missing the virtual desktops, I thought it was just a setting, to be honest, I do not use it much.

  • Dolphin works fine for me.
  • Yakuake works fine for me.
  • Don’t see any icons missing when using Breeze Dark.

In my case the problem is my missing proper theme, so I went with breeze for the time until I hope it is ported to plasma 6.

I had a crash on my CPU:s gpu, but I think that was firefox, not plasma even though plasmashell ofc also became affected after the loss of gpu, but it solved itself so I did not bother reporting it.

If it happens again, I will look deeper into the cause.

I really do not have much to complain about, sorry… xD

Oh yeah, I haven’t been able to try to deliver DEMOCRACY AND LIBERTY yet, but I have a feeling steam and gaming will work just fine.

Never forget Malevelon Creek

Thank you. So some of them might be related to KDE neon after all…
Therefore I think I will have to test another distribution with Plasma 6 in the future and circle back to my little bug list…

Edit: retested with Arch and Plasma 6.0.1 → the bugs are not related to KDE neon ! :slight_smile:

By reading your thread I now know about meta+g witch is now my new “overview” (previously meta+w. :smiley:
That one is actually useful! WOW!

I previously also knew about meta+t, I thought that would be more implemented in plasma 6.
Not that I ever use it, or would find it troublesome pressing shift, but still thought it would be the next thing.