Flatpak apps cannot open files via dolphin when stored on sftp

When I try to open a file in flatpak kwrite or flatpak kate via dolphin that is stored on my sftp location, both kwrite and kate say:
Unable to create KIO worker. Unknown protocol 'sftp'.
The file sftp://containers/home/containers/.bashrc could not be loaded, as it was not possible to read from it. Check if you have read access to this file.
I have added the sftp location in my .ssh/config as follows:

Host containers
    User containers
    RequestTTY yes
    RemoteCommand tmux attach || tmux

However, I can open the same file with both flatpak kwrite and flatpak kate when I use their Open File dialogs and use the Open File – Portal to browse to the sftp location in my Places sidebar on the left

When I do it this way I can see the path flatpak kwrite/flatpak kate shows for the file is /run/flatpak/doc/52f32db8.

This is OK as a workaround but it slows down the workflow a lot to open files after navigating to them when I am primarily working with the files in dolphin. Has anyone experienced this issue?

Fedora Kinoite 38
Operating System: Fedora Linux 38
KDE Plasma Version: 5.27.6
KDE Frameworks Version: 5.108.0
Qt Version: 5.15.10
Kernel Version: 6.4.4-200.fc38.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1070/PCIe/SSE2

Is this issue still happening?

Yes it is still happening. I’ve tried it with multiple sftp servers I have in my .ssh/config and I get the same error