Flatpaks not opening in kde neon

when trying to open a flatpak from the app launcher, nothing happens. when trying to run from konsole i get the following

nxegl: Error opening log file.
nxegl: Error is 30 ‘Read-only file system’.
nxeglInterposeInit: Output suppressed.
error: Failed to sync with dbus proxy

i’m not sure exactly when this started but may be related to an update? currently i have plasma 5.27.5 and discover says i’m up to date. thanks for any help!

The error message indicates that something is wrong with your system: DBus is broken because it isn’t expecting the filesystem where it’s storing its log files to be read-only.

Have you deliberately made certain volumes or folders read-only? Or done anything similar recently? Does this ring any bells?

the only thing i’ve used this computer for in the past week has been web browsing in firefox, and the odd kcalc calculation (which is a flatpak on my computer) i remember running an update earlier last week and not being able to use kcalc after that, but i figured i just needed to reboot. after rebooting and more updates, now i’m here.

i am able to download files from firefox like normal, so that’s not read only, and doing the below seems like it’s normal? i’m not sure, I’ve used linux for a couple years but i’ve never ran into this before (and would prob still be considered a noob, anyway)

$ grep -w “ro” /proc/mounts
ramfs /run/credentials/systemd-sysusers.service ramfs ro,nosuid,nodev,noexec,relatime,mode=700 0 0
/dev/loop0 /snap/bare/5 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/loop1 /snap/core18/2745 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/loop2 /snap/core22/617 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/loop3 /snap/core22/634 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/loop4 /snap/gnome-3-28-1804/198 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/loop5 /snap/gtk-common-themes/1535 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/loop6 /snap/snapd/18933 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/loop7 /snap/snapd/19122 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/nvme0n1p1 /boot/efi vfat rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro 0 0

did you fix it yet? I have same issues. I feel like its related to some nvidia stuff.

i got impatient and reinstalled the OS :sweat_smile: flatpaks work now, but i’m worried about future updates

then i might restore from backup.

same thing for me when I try to open Microsoft Edge in Flatpak. My Firefox Snap is fine though

$ flatpak --verbose run com.microsoft.Edge 
F: No installations directory in /etc/flatpak/installations.d. Skipping
F: Opening system flatpak installation at path /var/lib/flatpak
F: Opening user flatpak installation at path /home/jgamao/.local/share/flatpak
F: Opening user flatpak installation at path /home/jgamao/.local/share/flatpak
F: Opening system flatpak installation at path /var/lib/flatpak
F: Skipping parental controls check for app/com.microsoft.Edge/x86_64/stable since parental controls are disabled globally
F: Opening user flatpak installation at path /home/jgamao/.local/share/flatpak
F: Opening system flatpak installation at path /var/lib/flatpak
F: /var/lib/flatpak/runtime/org.freedesktop.Platform/x86_64/22.08/4ba47479a973c9a243112c43f8f58244af34457611e2a26bba8595d08a2b31d7/files/lib32 does not exist
F: Cleaning up unused container id 371326165
F: Cleaning up per-app-ID state for com.microsoft.Edge
F: Allocated instance id 1332651396
F: Add defaults in dir /com/microsoft/Edge/
F: Add locks in dir /com/microsoft/Edge/
F: Allowing wayland access
F: Allowing x11 access
F: Allowing pulseaudio access
F: Pulseaudio user configuration file '/home/jgamao/.config/pulse/client.conf': Error opening file /home/jgamao/.config/pulse/client.conf: No such file or directory
F: CUPS configuration file '/home/jgamao/.cups/client.conf': Error opening file /home/jgamao/.cups/client.conf: No such file or directory
F: CUPS configuration file '/etc/cups/client.conf': Error opening file /etc/cups/client.conf: No such file or directory
F: Running 'bwrap --args 47 xdg-dbus-proxy --args=49'
nxegl: Error opening log file.
nxegl: Error is 30 'Read-only file system'.
nxeglInterposeInit: Output suppressed.
error: Failed to sync with dbus proxy

Make sure both your system and the installed Flatpaks are up to date (using flatpak update)

First thing I did.

None of my Flatpaks are opening up:

  • Kasts
  • Anydesk
  • Microsoft Edge

Flatpaks on my Rocky Linux 9 VM are working, though

I have same problem
Is there any solution?

/usr/bin/flatpak --verbose run --branch=stable --arch=x86_64 --command=kruler org.kde.kruler
F: No installations directory in /etc/flatpak/installations.d. Skipping
F: Opening system flatpak installation at path /var/lib/flatpak
F: Opening user flatpak installation at path /home/fasiko/.local/share/flatpak
F: Opening user flatpak installation at path /home/fasiko/.local/share/flatpak
F: Opening system flatpak installation at path /var/lib/flatpak
F: Skipping parental controls check for app/org.kde.kruler/x86_64/stable since parental controls are disabled globally
F: Opening user flatpak installation at path /home/fasiko/.local/share/flatpak
F: Opening system flatpak installation at path /var/lib/flatpak
F: /var/lib/flatpak/runtime/org.kde.Platform/x86_64/5.15-22.08/1fb61aab6f8783bd5177eeccf98a9653cdecb168d7895d160adfe09e4b7bb503/files/lib32 does not exist
F: Cleaning up unused container id 1838903547
F: Cleaning up per-app-ID state for org.kde.kruler
F: Allocated instance id 1290327713
F: Add defaults in dir /org/kde/kruler/
F: Add locks in dir /org/kde/kruler/
F: Disallowing network access
F: Allowing dri access
F: Allowing wayland access
F: Allowing x11 access
F: Running 'bwrap --args 43 xdg-dbus-proxy --args=45'
nxegl: Error opening log file.
nxegl: Error is 30 'Read-only file system'.
nxeglInterposeInit: Output suppressed.
error: Fallo al sincronizar con el proxy de dbus
grep -w 'ro' /proc/mounts
ramfs /run/credentials/systemd-sysusers.service ramfs ro,nosuid,nodev,noexec,relatime,mode=700 0 0
/dev/loop0 /snap/acestreamplayer/12 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/loop1 /snap/core18/2721 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/loop2 /snap/core18/2745 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/loop3 /snap/snapd/18933 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/loop4 /snap/snapd/19122 squashfs ro,nodev,relatime,errors=continue 0 0
/dev/sda1 /boot/efi vfat rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro 0 0

i just ran an update on my freshly installed kde neon and checked to see if any flatpaks i downloaded after reinstalling yesterday were still working, and I encounter the same error as before again:

$ flatpak run page.codeberg.Imaginer.Imaginer
nxegl: Error opening log file.
nxegl: Error is 30 ‘Read-only file system’.
nxeglInterposeInit: Output suppressed.
error: Failed to sync with dbus proxy

the update i just downloaded can be seen here (it’s pretty big so i put it on a pastebin) Start-Date: 2023-05-15 17:09:59Commandline: packagekit role='update-packages' - Pastebin.com

Flatpaks were working before I installed this update.

So currently there is this page and this reddit page that highlights this problem.

I currently use AlmaLinux 9.2 (migrated from 9.1) with kde which has this current problem. I’m really not sure how to fix this. I’m also very frustrated since I rely on flatpaks for some apps I use daily. Addition to the frustration is that there is no solution to this new problem.

Now maybe I’ll find a way to install each app manually or even build them.

I believe nxegl is part of Nomachine’s accelerated remote desktop. On my system I had to completely uninstall (not just disable) Nomachine to get flatpak working again.

1 Like

Today I had updates from EPEL9 which gave me KDE Plasma 5.27.4 which made most of the flatpak apps work normally again. By default 5.27.4 defaulted to using wayland which did not bother me much.
The only flatpak app that is not working is Zeal which I’m also trying to fix it later on.

thank you, i had same problem, and removing nomachine helps!

Oh dang :frowning: I depend on NoMachine for my IT work.

But why would NoMachine conflict with Flatpak?

And my Rocky Linux 9 (Flatpak 1.12.5) also has NoMachine, so why is that one fine? Guess I may have to use that one for now.

Thanks so much! Removing nomachine seems to have fixed it

This is probably something that ought to be reported to NoMachine’s developers.

I opened an issue regarding this. Thanks for finding this out.

1 Like