Flicker issues with KDE at frame rates >100 fps

Hello Everyone,

I’ve reached out on reddit about this issue, although so far all I’ve gotten is ads/bots, so I’ll post this issue here. Anyway, I’ve recently upgraded my PC setup so that I could achieve a display of 4k 144hz. The main parts of my setup consist of an Eve Spectrum 4k 144 Hz Monitor 27” (Glossy) monitor, a AMD Ryzen 7 7800X3D CPU, a Sapphire NITRO+ Radeon RX 7900 XTX 24 GB Video Card, and 32 GB of ram. I’m using Display Stream Compression as well (DSC: 1.4) with the monitor in order to make 4k 144hz possible.

I’m currently using KDE Wayland (using Nobara as the distro) to take advantage of Adaptive Sync which Gnome KDE still seems to struggle with. Also just generally prefer KDE to Gnome in general. I also have Windows installed on a separate hard drive for doing things I can’t figure out in Linux in the rare circumstance Wine or an equivalent doesn’t work for me or if I just want to check something.

Using the KDE Wayland setup, I have no issues as long as I don’t go above 100 fps. However, if I try to increase my FPS beyond this to 144 Hz or even 120 Hz, I start getting intermitant “flickering” and occasionally even a quick “black screen” followed by the display coming back up. This is pecular in that if I setup Windows to run at 4k 144 Hz, no flickering occurs.

I’ve tried a few things to resolve this issue, none of which have worked. Specifically…

  1. I tried 2 different DisplayPort cables in case that was the issue. Specifically, I’ve tried these 2 cables listed below (which both claim to do 4k 144 Hz), but this has not solved the problem. Also, would post links, but apparently newer users are limited in posting links.

-Stouchi DisplayPort Cable 2.1, 16K 10FT/3M DisplayPort Cable 80Gbps 16K@60Hz, 10K@60Hz, 8K@60Hz HBR3 4K@60Hz/144Hz 5K@60Hz 1080P@240Hz Support FreeSync G-Sync HDR10 for Gaming Monitor Graphics Card

-KabelDirekt DP 2.0 cable: 8K DisplayPort 2.0 Cable – 10ft – DP 2.0 Cable with Special A.I.S. Shielding for Gaming PCs/Gaming laptops and high Resolution 4K / 8K or Super Fast 144Hz, 240Hz or 360Hz by CableDirect

  1. At one point I thought that a lower Color Bit Depth may allow me to have non-flickering higher frame rates. This may still be true, although Windows with DSC is still able to achieve 4k 144 Hz with a color bit depth of 10, I’m not sure. Anyway, Windows via Radeon Crimson Edition (and maybe some other way) can flip this from 10 to 8 (or 30 to 24 if counting all colors). KDE Linux doesn’t let this be changed as easily, although (apparently…?) it can be changed by adding the line KWIN_DRM_PREFER_COLOR_DEPTH=24 into /etc/environment according to the below topic I made some months ago dealing with a somewhat similar issue. This hasn’t gotten rid of the flickering though. The topic is here by the way…
    -KDE Wayland - View/Set Color Bit Depth?

  2. I also tested whether Display Stream Compression is working. My monitor has 3 settings for DisplayPort mode, being 1.2, 1.4 without DSC, and 1.4. Using 1.4 without DSC has 4k 120 Hz show up in my options menu (although 144 Hz isn’t there), but trying to select it results in a black screen that only goes away once the system resets to a previous fps. Using 1.4 instead does let me go to 144 Hz and I can actually get the display to work…although with flickering. So, DSC seems to be doing something at least. Not sure how to test if it is working properly.

In summary, with Windows running 4k 144 Hz without issue, the monitor appears to have the ability to run this resolution/frame rate. I’ve also tried 2 DP cables in case 1 had an issue with Linux for some reason, messed with changing the color depth, and also looked into where DSC was working correctly.

I believe this means that KDE Wayland Linux seems to be the cause of the flickering, whether it be a single setting or not playing nice with a component of the setup. I’m not sure what else to look into to get rid of the flickering at high fps. Does anyone have any ideas as to the cause and/or a solution for getting rid of the flickering? If it helps, I added an image of some of my settings through neofetch and Display Settings (I’ve tried both Automatic and Always for Adaptive Sync; showing the latter).

Any info/help would be appreciated.

That sounds like the connection isn’t very stable, and if the hardware works, then that’s most likely a driver bug.
If you report that at https://gitlab.freedesktop.org/drm/amd/-/issues you might get more qualified help