Floating Panel Stuttering/Visual Bug

Hi all,

I’ve encountered a strange issue in the floating panel, where it stutters and flickers between transparent and opaque when I either open a window (forcing the panel to anchor on the bottom of the screen) or switch to a virtual desktop with a window open/not open.

I’m not sure if this is a known bug or whether it’s specific to my system. I’m running:

  • OS: Arch Linux 6.8.9 kernel
  • Plasma Version: 6.0.4
  • Graphics Platform: (issue present on both X11 and wayland sessions)
  • Laptop Hardware: ThinkPad T480s
  • CPU: intel i5-8250U
  • GPU: intel UHD Graphics 620

Unfortunately pictures cannot really describe the issue (which seems to just be with the animation), so I have uploaded a video to Imgur:
(I have intentionally slowed the animation speed to better show the transition).

I’m wondering if this is a known bug, and if anyone has any solutions/diagnoses? If not, what should I include in a bug report to be most helpful for any developers potentially addressing the issue?


I also has this behavior with floating panels, with Nvidia GPU though.
I was talking about it yesterday here :

Thanks for your input Han. I’ve found it’s definitely an issue on my end with both the X11 and wayland sessions, even though I run pure intel/intel CPU/GPU.

Interestingly, I tried this on my main PC (also arch/KDE/Wayland, but Ryzen/Nvidia CPU/GPU setup) and it’s noticeably better. There’s still a very quick white outline and (sometimes) a pale outline of the final location of the panel, but it’s much less pronounced and there’s no transparency glitches. It’s possible that the first two behaviours are intentional design, but the transparency flickering is definitely weird.

On rare occasions, the quick white outline that appears around the panel doesn’t become dark again so much as it “vanishes”, and I have a 1 pixel gap between maximized windows and the anchored panel. I cannot reproduce this however, it doesn’t happen often.

So I think this is a kde problem, but it could also be accentuated by hardware. Additionally, the fact that I use a HiDPI monitor on my laptop could contribute to this (font rendering had problems in HiDPI monitors for wayland), but I would have thought that would mean the issue was absent from the X11 session.

Interested to see if there’s any development on this.