Frustrating input delay for password on lock screen

About 6 months ago I switched from Pop!_OS to EndeavourOS (and from the Gnome-based Pop DE to KDE Plasma). I am very happy with the switch - Activities, and a little script I wrote to change my default browser/profile based on them, have been a game changer for me!

BUT the lock screen has been a constant source of frustration.

In Gnome/Pop!_OS I could sit down at my locked computer, start typing my password, hit enter, and be back to my desktop without any delay. Sometimes before my monitors even finished waking up.

If I try to do the same with Plasma, not all my password will be captured, or part of it will be in the input on on screen and part will be on the other, and I’ll be sitting and waiting for the naughty timeout to be over so I can put my password in again.

So, instead of that, I hit ctrl, wait for the screens to wake up, make sure I have one of the password fields in focus, and then type my password. It is worse than Windows!

I know this can be so much better, but I have not found any settings that effect it. The best I can to is tell my computer not to lock automatically.

Maybe setting the power to never turn off the screens would work, but I like to have them off when I’m not using them.

Questions:

  1. Have you encountered this? If not, what settings do you use to avoid it?
  2. Do you know why Gnome handles this so much better than Plasma? Is there a non-GUI way to get that behavior in KDE?

i always hit enter before i start typing my password … seems to keep me out of that loop you describe and i have to do the same thing in win10.

the naughty timeout countdown can be hacked to shorten it, but i didn’t find it in my notes atm.

I switched my monitor from hdmi to displayport so that the monitor wakes up quicker.

I will try this new habit … still much slower that Gnome :-/

you make up for it in how much more productive you can be in KDE than in gnome :wink: