Games not smooth on Plasma 6 wayland

Hi people

I’'m currently using Fedora 40 with Plasma 6.0.3 wayland. I seem to be having weird performance issues while playing some games. I do get the expected FPS, but the games don’t feel smooth at all, I’m not sure what you’d call it. Mouse movement also isn’t smooth at all, so aiming and such becomes really hard. Also this seems to happen only on a few games (I’ve reproduced this on Counter Strike 2 and NierAutomata so far). This is on a laptop with an AMD CPU and iGPU, so no Nvidia at play.

If I miss some details, please let me know, I’ll update accordingly.

Are you sure it is running on the GPU and not on the CPU graphics?

I have more knowledge about getting these things to work on nvidia but lets try out:

inxi -G
lspci | grep VGA
glxinfo | grep "OpenGL renderer"

This won’t show what is actually used while gaming, but it’s a start.

I actually only have integrated CPU graphics, that’s what I meant by iGPU! But still, I do get fairly good fps, around 60-70 on CS2 @ 1080p consistently, which is more than what I got on windows. So it’s definitely something else!

Also I forgot to mention, the same games run perfectly fine on Gnome wayland, so it’s definitely something up with Plasma.

Thanks for helping :slight_smile:

Yeah, sry, I got lazy and didn’t actually look up your cpu. You are correct.

  1. Please use the “insert code” (the </> button in the text window you are typing in instead of pictures.
  2. You have nothing loaded for the wayland compositor.
  3. You have no driver specified for vulkan

2 and 3 could be different for you though, since the drivers for you are in the kernel rather than outside like I do with nvidia.

But the GPU is there and identified.

Sounds like frametime spikes to me…
Have you tried installing mangohud, configure it to show frametimes with a histogram and see if you get spikes in the frametimes?

How do you start the game?
Is there a difference between using vulkan or openGL? (I am assuming you play through steam)

I’ll do that from now on, my bad.

Yeah I get lots of tiny spikes, this just might be it! I do run it through steam, looked around to get it run through vulkan, apparently I need to let it precompile shaders. Will update in a while. Thanks!

If you use proton (per game > properties > Compatibility > Force the use of specific steam play compatibility tool) you can just add stuff to the “launch options” per game in steam. I dont have my notes how to do it here, but you can search the interweb. (my fingers want to type PROTON_USE_WINED3D=1 %command% but use the interweb and make sure that is correct)
This also means steam will download pre-compiled shaders (if enabled in the steam settings, witch I think is default). :slight_smile:

I also recommend using proton-ge.
(long live the glorious eggroll)

CS2 is Linux native, so don’t need to run it through proton :slight_smile:

Just adding -vulkan to the launch option works apparently. I’ll have to check on the shaders tho, the performance is still far worse than before.

I know, but it is also a well known fact that both CS:2 and TF2 very often run better under proton than natively.
I dont play these games, but with f.ex Valheim, the game runs better on my machine using proton than running it natively.
Proton is just that good: :slight_smile:

Ah well, I’ll just go with proton then if nothing else works.

Cheers :smile:

Please let us know how it went. :slight_smile:

Okay this is the weirdest.

The game now works fine when playing with bots but again struggles to run when playing online!!! I’m more amused than anything :smile:

I’m giving up, proton it is!