Games opening on the leftmost monitor (Opensuse + KDE + Wayland)

Hello !
I am running games on my Opensuse Tumbleweed distro, with KDE + Wayland.

I am encountering problems for setting my main screen when launching full screen games. They always are opening on the leftmost monitor which is clearly not my main monitor (I have set my QHD monitor as the main one on the windows manager).

I have tried to launch the game on the left screen and then use ALT + F3 and move the window to the right screen, but it is impossible chosing the resolution of my QHD screen (the leftmost screen has a much worse resolution).

One workaround I had found is to use xrandr --output DP-3 --primary (DP-3 is the identification of my main screen). It worked for a while, but since a recent update of OpenSUSE, I do not know why, but it does not work anymore… When using this command, my games try to be displayed on my main screen, the game launches itself, I hear the sound, but nothing is displayed on my screen (neither the others).

I have also tried to install kwin rule “Always display on main screen” or “Always display under mouse cursor” but nothing worked : the games are still launching on the leftmost screen.

Has someone here found a fix ?

Thanks in advance for answering :slight_smile:

I don’t think xrandr works on wayland. Afaik xrandr is xorg only.

Please post the output of kscreen-doctor -o

It seems that the full screen games are still using the xorg settings… annoying :frowning:

Here is the result of kscreen-doctor -o

Output: 1 DP-1 enabled connected priority 3 DisplayPort Modes: 0:1680x1050@60*! 1:1280x1024@75 2:1280x1024@60 3:1440x900@60 4:1280x800@60 5:1152x864@75 6:1280x720@60 7:1024x768@75 8:1024x768@60 9:800x600@75 10:800x600@60 11:640x480@75 12:640x480@60 13:720x400@70 14:1280x1024@60 15:1024x7 68@60 16:1280x800@60 17:1600x900@60 18:1368x768@60 19:1280x720@60 Geometry: 9,0 1527x955 Scale: 1.1 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: unknown Output: 2 DP-3 enabled connected priority 1 DisplayPort Modes: 0:2560x1440@144*! 1:2560x1440@120 2:2560x1440@120 3:2560x1440@96 4:2560x1440@72 5:2560x1440@60 6:2560x1440@60 7:2560x1440@60 8:2560x1440@50 9:2560x1440@48 10:1920x1200@144 11:1920x1080@120 12:1920x1080@120 13:1920x1080@60 14: 1920x1080@60 15:1920x1080@60 16:1920x1080@50 17:1600x1200@144 18:1680x1050@60 19:1280x1024@75 20:1280x1024@60 21:1440x900@60 22:1280x960@60 23:1280x800@60 24:1152x864@75 25:1280x720@60 26:1280x720@60 27:1280x720@60 28:1280x720@50 29:1280x720@50 30:1024x768@75 31:1024x768@70 32:1024x768@6 0 33:832x624@75 34:800x600@75 35:800x600@72 36:800x600@60 37:800x600@56 38:720x576@50 39:720x576@50 40:720x480@60 41:720x480@60 42:720x480@60 43:720x480@60 44:640x480@75 45:640x480@73 46:640x480@67 47:640x480@60 48:640x480@60 49:720x400@70 50:1600x1200@60 51:1280x1024@60 52:1024x768@60 5 3:1920x1200@60 54:2560x1440@60 55:1920x1080@60 56:1600x900@60 57:1368x768@60 58:1280x720@60 Geometry: 1536,150 2048x1152 Scale: 1.25 Rotation: 1 Overscan: 0 Vrr: Automatic RgbRange: unknown Output: 3 HDMI-A-1 enabled connected priority 2 HDMI Modes: 0:1920x1080@60*! 1:1920x1080@60 2:1920x1080@60 3:1920x1080@60 4:1920x1080@50 5:1920x1080@50 6:1920x1080@48 7:1680x1050@60 8:1600x900@60 9:1280x1024@60 10:1440x900@60 11:1280x800@60 12:1152x864@60 13:1280x720@60 14:1280x720@60 15 :1280x720@60 16:1280x720@50 17:1024x768@60 18:800x600@60 19:720x480@60 20:720x480@60 21:720x480@60 22:720x480@60 23:640x480@60 24:640x480@60 25:640x480@60 26:1280x1024@60 27:1024x768@60 28:1280x800@60 29:1920x1080@60 30:1600x900@60 31:1368x768@60 32:1280x720@60 Geometry: 0,955 1536x864 S cale: 1.25 Rotation: 1 Overscan: 0 Vrr: Automatic RgbRange: unknown

The right screen is DP-3 and it seems to be configured as the main one… So I don’t know

Could be because they are running on xwayland? I am unsure if xrandr works for xwayland.

Do your games start on Output: 1 DP-1 ?

1 Like

Yes, the games are starting on DP-1.

I have manually inverted the cables in my graphic card, and now the games are running on the DP-1 (that was the DP-3 before, so the right screen).

The problem remains the same as when I used xrandr --output DP-3 --primary : the games seem to be opening on the right screen, the sound is okay, but nothing is displayed on the screen.

To be clear, xrandr --output DP-3 --primary worked some days ago, but does not anymore for 4 days… Maybe should I plan to re-install my opensuse distro…

I don’t think this is an issue on your end. It seems like multiple people have issues with that on wayland, even on gnome.

I have not found a solution or workaround yet. But I will keep looking.

Maybe some1 with more experience with multi monitor will chime in.

Multi screen on wayland is still an horrible experience, in my opinion… it is sad, because I would like to love wayland ^^’

You probably want to use gamescope.