Git Gui broken on Plasma wayland

Hi, when using “git gui” on Plasma wayland (5.27) the UI comes up broken as shown in the image below.

The same issue is described e.g. here: Git-Gui / Gitk Broken interface cause crash on kde plasma wayland - Stack Overflow

According to KWin’s debug console (qdbus org.kde.KWin /KWin org.kde.KWin.showDebugConsole) Git Gui is run as an X11 window which is fine given that there’s currently no Wayland support in TK as far as I know. However I would have expected the application to run correctly on XWayland.

Done anyone else observe this behavior or does this occur only on certain hardware configurations?

Thanks!

It work for me (once I fixed a problem due to some misconfiguration related to $XAUTHORITY). I have no idea if it might be hardware, or just a problem with package versions or version incompatibility between different pieces. I have frameworks 5.112.0, plasma 5.27.9, kde apps 23.08.3, wayland and xwayland 23.2.3, tk 8.6.13, tcl/tk 8.6.13. My video card (from lspci) is:

1c:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde XT [Radeon HD 7770/8760 / R7 250X]

(Thanks for bringing this up, as I hadn’t known about gitk, and it does look useful.)

WAIT: I did my testing with “gitk” not “git gui.” The latter started by complaining about lots of “loose objects” and wanting to compress the database. When it finished, it showed something very similar to your screenshot. (I currently have lots of unstaged chagnes.) Why do you think it’s broken?

Hey @ostroffjh, thanks a lot for testing. So it does not seem to be limited to a particular video card. My card is:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)

Interestingly gitk indeed seems to work most of the time although I had the problem there as well.

Meanwhile I tested git gui on my machine on Gnome with Wayland (using the Fedora Workstation live image) and the issue does not occur there. So it looks as if the problem is specific to kwin/Plasma and at least be somewhat specific to the application being run. I tried a couple of simple TK demo applications (both via Python and tcl) and those worked fine.

So far I’m pretty clueless as to why this occurs. As a next step I’ll probably see if I can come up with a stripped down version of git gui that still triggers the issue. Thanks for ruling out the video driver issue. :slight_smile:

I’m still not quite sure what you think is broken. I get the same window under X as I do under Wayland. (I “think.” I have not yet compared screenshots to confirm.)
When you run “git gui” you can get the same window that launches with gitk by the menu item Repository/Visualize Current Branch History. (it actually uses the name of the branch.)

Sorry, I probably explained the problem poorly.

On X11 the application looks and works as expected. Here’s a screenshot of the git gui window as shown on Plasma/X11.

Opening the application in the same git repository on Plasma/Wayland displays the window in various levels of brokenness.

Sometimes the outline of the widgets is displayed, but the widgets are rendered incompletely, some of them are not rendered at all and letters are missing in labels as shown below.

Sometimes the widgets display as black rectangles as shown in the screenshot below and are only rendered (but still incompletely) when the mouse cursor is moved over them.

The problem occurs on two of my machines both with Intel graphics adapters on Arch with Plasma 5.27.10:

  • 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
  • 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)

To follow-up and clarify, I have NOT seen that type of breakage, so perhaps it might be video card or driver related.

Thanks for the follow-up and the clarification!