Google Drive with Dolphin broken with Plasma 6?

Just installed Plasma 6, and I notice that my networked Google Drive isn’t working. When I click it, I do get the “root” items in the google drive, but clicking on any folder on that drive gives me “The file or folder /google40/folder_name does not exist.”

I’ve deleted the Google Drive from the Network Folder and reinstalled a new one, but the problem persists. This worked perfectly in Plasma 5.

Is this a new issue that I should report, or am I doing something wrong?

3 Likes

I got the same issue, I installed it on KDE 6 and logged in with my university account. Then I accessed some folders and Dolphin says something like you: “The file or folder /google40/folder_name does not exist.”
If you say that in KDE 5 worked well, I believe it’s a KDE problem… anyway I’m waiting a more trustworthy answer.

So, for some reason now it’s working, I believe because I updated Dolphin… maybe try updating the all the packages (I’m on Arch so I have the latest release of Dolphin ATM)

Thanks for the feedback. I’m using Arch as well, but the issue is definitely hit-or-miss. Sometimes it actually works, other times (in fact most of the time), although I can access the root directory of google drive, opening folders results in the “not found” error.

I’m on EndeavourOS with this same issue. has anyone found a fix for it yet? or does anyone know if a bug has been filed?

Well, recently Google broke our drive access and requires kio-gdrive to pass through some verification to prove to google, it passes its criteria:

Google requires kio-gdrive to pass through those hoops yearly.

And note kio-gdrive has no active maintainer.

Still efforts are underway. That takes place over the kde-devel mailing-list. No time-frame, this is done on the free time of community member.

This might get fixed, but it is still a pain to go through…

3 Likes

Well those issues might not have concerned users yet.

Is that verification request by google responsible for the problem mentioned here? I also have the same issue on Fedora 40 beta. Can access the root and with a trick even a subfolder.

You have to try to open the subfolder then close dolphin. reopen dolphin again and try to access the same folder and this time it works. But in general it is extremly broken as is.

Is there already an issue to track this?

I don’t think so.
But it might cause some issues later on.

There are problems still with kio-gdrive, I tried to use it and I could not log in my google account to reproduce the issue because the authentication did not accept the embedded browser we are currently using for this.

Here the issue might be very simple and not even specific to gdrive:/ but I can’t say.

1 Like

Just thought I would add my 2 cents.

Fedora 40 KDE and this issue seems to persist.

1 Like

I have the same issue after upgrade Fedora from 39 to 40. If I try to open Dolphin → Google Drive → The file or folder /myaccoung@gmail.com/Working Files/ does not exist. and “Loading canceled”. Do you have any news about this case?

1 Like

Manjaro Linux user here, same issue. Exactly same one, I can list the structure, I can even open a file in the root google folder, however when trying to access a subfolder, I am unable to do so.

1 Like

Do you have any updates? Today I run all pending updates on my OS (Fedora 40) and reboot it, but the issue still exist. :frowning:

Honestly, I have gave up on it, I have configured a service rclone-gdrive with a configuration, that I have up, and syncing into gdrive folder in my home folder.

Google is really the one to blame tbh, guys from KDE are doing a really great job.

3 Likes

Good afternoon people!
Fedora 40 user, KDE Plasma.
Exactly the same, I can list the main structure, but when trying to access a subfolder loading error.
=/

KDE Gear 24.05.2 includes a fix for opening folders in kio-gdrive