GPU Rendering is working unter ffmpeg on CMD but not in KDEnlive

Hello all,

i’am using here Kdenlive 23.08.5 on Kubuntu 24.04LTS. I have an nvidia 4090 and i would like to use it for render videos.

i’ve copied the default h264 profile and changed only to vcodec=h264_nvenc. But if i use this i get an error:

Rendering of bla.mp4 aborted, resulting video will probably be corrupted.
[h264_nvenc @ 0x77926c201e40] Interlaced encoding is not supported. Supported level: 0
[h264_nvenc @ 0x77926c201e40] No capable devices found

If i do the same with ffmpeg on the CMD it is working with the nvidiacard. So what i have to do that i can use the card with kdelive too?

Very thanks :slight_smile:

maybe update? 23.08.5 is 4 months old and that might work on newer versions

The version is certainly not the problem. As there are articles and instructions that have already successfully managed this with much older versions. But none of the instructions I have found have been able to do this so far.

Have you tried the built-in Hardware Accelerated render profiles/presets? There is one NVENC H264 ABR that should do the trick? Perhaps there is a parameter conflict in the standard h264 profile.

Please note that Kdenlive passes on the parameters to MLT which in turn uses them for the encoding piece (passing them on to ffmpeg).

If using the HW accelerated profiles do not work either, I suggest you log a bug report, either using this link, or via Kdenlive Menu > Help > Report Bug