HDR makes all Windows really dark


I have a Samsung G9 Neo LS49AG952NNXZA HDR monitor. It works amazingly well in Windows 11. When I try to enable HDR under Nobara Linux 39 KDE Plasma Version 6.0.1. It makes all the windows very dark.

Is there a workaround for this?

github /matinlotfali/KDE-Rounded-Corners/issues/175

To disable it:
Settings > Apps & Windows > Window management > Desktop Effects > Uncheck: ShapeCorners and Apply (Fixes it)