Hide Titlebars of Maximised Windows

In my opinion, titlebars are a total waste of space on maximised windows.

Hiding window borders (including titlebars) is easily done on Plasma on a per-window basis using the Window Operations Menu, default shortcut: Alt+F3, or on a per-application basis, by setting Window Rules. But that is quite slow and cumbersome, as you would have to do it manually for every window. Not good. You can also set a keyboard shortcut to hide and show window borders. Better, but you still have to do it manually.

Fortunately, there also exists a hidden setting in KWin to automatically hide titlebars and window borders on maximised windows. To apply it, edit the following file:

~/.config/kwinrc

Find the section [Windows] and add BorderlessMaximizedWindows=true under it. It should look something like this:

[Windows]
BorderlessMaximizedWindows=true

Log out and log back in. Open any application and maximise it to see the effect.

This way you have the best of both worlds: floating windows still have titlebars and fancy shadow borders and whatnot, and maximised windows have none of that clutter, letting you utilise your screen real-estate to the fullest.

7 Likes

What happens to the Window Control Buttons when you use this setting?

One of the reasons why I have not used this setting for all my Windows is I use some windows in unmaximsied and Maximised modes, and want to switch between those modes… removing the title bar (AKA Window Decoration) also removes the Window Control Buttons.

As a Consequence I use this only for the Windows I only ever run maximised.

Firefox is the only App I can run sans the Title Bar, and still have the Window Control Buttons available, but that is a Firefox thing

1 Like

If you decide to hide the titlebars on maximised windows, when the window is maximised you don’t have control buttons. When The window is not maximised, you have the titlebars normally, with the control buttons.

Personally, I don’t need the control buttons on maximised windows. But if that is a problem, you might not want to do this.

I was certain that was the case.

I will continue to do it the way I currently do… Only those windows that I only use at Maximum (In other words, I never use them in any other size mode) will be set to No Title bar.

I don’t use titlebars at all, maximized or unmaximized. I’ve set it through my windowdecorator. To control them, there are options . Me, I’ve always used the active control widget, but there are others that provide titlebar buttons on the panel. As for dragging , use the meta or alt ( whatever your choice) or you can even make a panel app to do just that. It’s a pitty a custom toolbar button still isn’t implemented in kde apps for that would give a more csd styled layout. In either case, the active window control provides an option to undecorate maximized windows if you like and a mouse scroll up/down to max/unmax as well as min/max/close buttons.

1 Like

Actually I just realised that the windows I run at Maximised is pretty much most of my Windows, there are only a small number, like kCalc and Kate and ‘temporary’ konsole windows that don’t get the Maximised treatment, even windows like Kwallet and Mullvad which aren’t run at maximised can be run without a title bar, as they are tiled on one workspace permanently.

I guess I’ll give your idea a go.

On my netbook (where screenestate is scarce) I also disable titlebars for maximised windows.

To get Min, Max and Close I have an autohide plasma panel in the upper right corner with an active window control plasmoid (which also sports a GUI switch to disable the titlebar). It’s generally hidden unless I move the cursor to that very spot.

ymmv

4 Likes

Here is how I use this feature:

  1. System Settings > Window Management > KWin Scripts > Hide Titles
  2. Add also these widgets: Window Buttons, Window Title, Global Menu
3 Likes

The active window control widget takes care of three out of those and adds some more if you like.

1 Like

Thanks.
It wasn’t working properly when I tried it 3 years ago, and tried again now: installing “qml-module-org-kde-graphicaleffects” seemed to help display the buttons this time.
Actually, I would be happy to use it instead of Window Buttons and Window Title if it the buttons could be positioned at the top right corner as well.
For I’ve recently changed my preference back to the default position for system-wide consistency - like the close buttons of tabs, notifications etc.

You can use the Window Buttons plasmoid in a top panel (which is what I do).

That’s in its’ settings.

Thanks. Yes, I saw it, but it didn’t work when I tried it earlier. However, it worked now.
Nevertheless, it seems Active Window Control is only good if you prefer window control buttons in upper left corner (Mac-style), because if you choose upper right, they are displayed (perhaps inevitably?) just at the right end of the widget, and not at the right end of the panel.
With a top panel configuration like mine, which has three groups of widgets (left,center and right), one would normally expect window control buttons of maximized windows to be at the top right corner of the screen, and using Window Title and Window Buttons makes more sense.

Then windows buttons is what you need. It makes no sense for the active window control widget to “split” itself up. If you want that it would take up the entire panel. In my case, I don’t use titlebars at all and use the mouse scroll function of the widget to max/unmax windows. As such I only need a close button ( although I can use a middle click to do it as well, so without any button). For me, since I sometimes switch to a tiling mode I only need to highlight the specific tiled window and max it using a mouse scroll. But no, if you want buttons in a specific place and the window title in another, you can’t use this widget. Unless you put two of course and hope they don’t clash by their settings.

I know it’s an ancient thread by internet standards, but so glad I found this. I’ve been searching for days trying to find the setting that brings titlebars back (I’ve no need to save 17 pixels of space, my screens have room, and I hate having to dig for buttons every time i want to unmaximize a window). This setting really should be a toggle in the settings UI.

1 Like

Haha old threads.

I saw this - feeling sad that my mouse gestures (working on X11 with easystroke) are having serious issues on Plasma 6… I dedicated so many tasks (screen corners, scripts, shortcuts) to shapes drawn on screen… and I don’t like clicking targets (like Window buttons). It seems a very Microsoft way of doing things… I find it offensive when there aren’t alternatives.

On Keyboard:

MetaPgUP toggles maximised windows. No controls needed.

With Mouse:

Generally you can drag windows from many areas - but certainly this is somewhere I enjoyed mouse gestures…

However, assuming one hand can reach the Meta key:

  • You drag windows by holding Meta and use Left mouse button to drag them.
  • You resize windows by holding Meta and use Right Click to resize them.
  • You can drag and resize maximised windows!

There is really no need for ‘buttons’ to click for these actions at all.

@Bregg - To ‘bring back’ titlebars, the window menu is still available with Alt+F3.