Hiding The KDE Panel

I used to be able to hide the KDE panel using.

qdbus org.kde.plasmashell /PlasmaShell evaluateScript "panel = panelById(panelIds[0]); if (panel.height > 0) {panel.height = panel.height * -1;}";

and unhide it using

qdbus org.kde.plasmashell /PlasmaShell evaluateScript "panel = panelById(panelIds[0]); if (panel.height < 0) {panel.height = panel.height * -1;}";

This would allow me to use a Virtualbox VM in, what I call, psuedo Full Screen… where the window has been stripped of it’s Window decorations, and it is set to Max Vertical and Max Horizontl.

In this psuedo Full Screen mode I can still access my other virtual Workspaces, but without the KDE Panel suddenly popping up as it would if I had it set to Hidden of Windows Can Cover modes.

Unfortunately this script seems no longer to work, since Plasma 5.27. Instead the panel reduces to about half it’s normal size… about 11 pixels (I have it set to 22 Pixels)

my system

Operating System: Manjaro Linux 
KDE Plasma Version: 5.27.3
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 5.15.105-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Pentium® CPU N3540 @ 2.16GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics
Manufacturer: Notebook
Product Name: W54_W94_W955TU,-T,-C
System Version: Not Applicable

Just looking around the Internet… I guess I’m not the only person for whon the Supplied panel setting options of Auto Hide and Windows Can Cover options are insufficient.

Someone who needs to have the Panel either Always Hidden or Always Shown, depending on current work flow.

Plasma 5.27 broke the work around of setting the Panel size to a negative value.

Do the Devs have any suggestions?

With regards to your psuedo full-screen mode. What is the goal of that, are you running an application in the VM that you want taking up the whole screen once you full-screen the VM session?

If so the panel option “Windows Can Cover” might be a workaround.

Unfortunately that is not the case.

Yes when I am using the VM I want the VM window to be Full Screen, so that the OS in the VM can be operated at the full resolution of the Monitor.

But running in Full screen Mode, means I am locked in to that work Space. Hence my work around of pseudo Full Screen Mode.

I was able to achieve this quite easily on a GNOME based Desktop, like Cinnamon, and indeed in the KDE3 desktop, back in the day, without the above mentioned work around. Back then I was able to work on 3 different Operating Systems at one time, with Windows and Mac hosted in VMs on my Mandrake/Mandriva KDE machines, switching seamlessly between them.

The problem with “Windows Can Cover” and indeed “Auto Hide” is they are designed to ‘Pop up’ when the mouse pointer hits the bottom of the screen… and I usually have the client OS Panel at the bottom of the screen, especially when I’m using Windows, so you can imagine how annoying it is to suddenly have your work flow interrupted in such a manner.

The work around people have been using, which I posted initially, of course, broke with whatever changes were made to the Panel for Plasma 5.27.

I’m trying to see what work arounds I can affect.

Going by the age of old Bug and Enhancement reports the KDE Devs appear to have no interest in fixing/adding this functionality.


EDIT: I may have have found, not a work around, but the actual way to do what I used to do on KDE3.

In System Settings → Work Space Behaviour → Screen Edges there are three check boxes at the top of the screen

Maximise Windows dragged to top edge

Tile Windows drgged to left or Right Edge

Behaviour Remain Active when Windows are Full Screen

This last one when checked seems to allow Windows to be Full screen (which is what I want for my VM Window) with the ability to switch to other desktops when desired.

If I remember correctly there was a similar option that made this possible on KDE3

So if this works the way I expect, I appologise to the KDE Devs.

The Behaviour setting checked

Ubuntu running Full Screen-resized

Ubuntu (in workspace 8… bottom centre) running in a Window set to Actual Full Screen.