How can I make active screen follow mouse cursor in Plasma 6?

This option seems to have been removed in Plasma 6. I preferred this, how can I restore it?

I also have this issue - active screen no longer follows mouse in Plasma 6.1, instead it looks to switch to “last interaction”, so if you move the mouse to another screen, that will be the active screen, but if you then use the keyboard to activate a window on another screen - that will become your active screen even though the mouse isn’t there.

This is really annoying with using Yakuake - I move the mouse to the screen where I want Yakuake to open, that has no windows, and trigger the shortcut - Yakuake opens correctly. If I then close Yakuake, focus moves to an existing window not on the screen where the mouse cursor and if I open Yakuake again - it will open in the other screen. So the process of “move mouse, trigger Yakuake open, trigger Yakuake close, trigger Yakuake open again” will open Yakuake in two different screens.

The change was reported by @ngraham in this TWIK post, which implies that the major change was in the 6.0 release, though I think the behavior change to activate screen on window focus change is more recent.

The change that annoys me is in MR!5625 where some one else has already detailed my exact issue. In the follow up discussion it was greed that the problem (my specific problem, I’m not sure about @pepsicide’s issue) can be solved by going to System Settings → Window Management → Window Behavior → Focus and enabling Separate screen focus.

From my limited tests now, this definitely improves the situation for me. Time will tell if the other aspect of the change (breaking LRU focus order) will be a problem.

After trying out “Separate screen focus” for a day, I disabled it - yes, it solves the Yakuake moving problem, but introduces a much larger problem: when switching between virtual desktops back and forth, it moves the focus in a really unintuitive way and that bothers me more than Yakuake moving.

I think losing the concept of “active screen != screen where the focused application is” is a problem.