How do I stop an application from defaulting to ‘Keep Above Other’ window behaviour?

I have an application (KeePassXC) that automatically sets ‘Keep Above Other’ as true on all of its windows, which is incredibly annoying. How do I stop this behaviour?

I think I accidentally activated it with a keyboard shortcut when I started typing something whilst focus was on the KeePassXC window, but I don’t know what I typed.

Kubuntu 23.10
KDE Plasma 5.27.8

Create a window rule with Keep above other windows set to Force and off


Or you could right click top left corner of the window, More actions > keep above all others (make sure it is unchecked).

Should not be needed to make a window rule for this.

You can also include the button on most windows as default (looking at you firefox) via KDE settings: Appearence > Window decorations > make sure the “keep above other windows” is included in the window decoration.

@bedna @arttuc Unfortunately neither of those has worked.

When I open the application (whether from the minimised tray icon or from fully closing and opening the program itself) the window has ‘Keep Above Others’ checked. I can uncheck that and it will work, but after I close the program (either minimising it to tray or fully closing it) the next time I open the window it will be checked again.

To me that suggests I’ve set some default setting somewhere, but I’m not super familiar with KDE so I don’t know where to look. As far I can tell there are no Window Rules set:

Have you checked if there is any setting in the application?
Yakuake f.ex on x11 has a setting in the application doing this without a window rule (does not work on wayland though, there you HAVE to have a window rule if you want it to stay on top).

As far as I can tell this used to be a KeePassXC setting but isn’t any more (I’m on 2.7.6).

BUT I reset my KeePassXC settings to default and it’s fixed it. No idea what happened, but looks like it was something with the app rather than KDE.

Scratch that, there’s a setting under the View menu tab for ‘Always on Top’ with the keyboard shortcut Ctrl+Shift+A, but the option isn’t listed in the Settings page. I must’ve activated that when mashing my keyboard.


It happens to all of us.

1 Like