How to change which Firefox runs in my application menu?

The stock FF on KDE NEon had issues running video chats on my desktop, so I installed the Flatpak version. The Flatpak version works perfectly. However, I can only run it from Discover (software manager) or once I run it from there, I can pin it to the taskbar. The only FF that shows up in the application menu is the stock version. I’ve tried running both and looking at the name of the process in system monitor. The stock version is called firefox while the Flatpak version is called firefox-bin. If I try to run firefox-bin in the terminal, I get zsh: command not found: firefox-bin, so I can’t change the application menu command to that. Even more confusing, if I run firefox in the terminal, it opens the Flatpak version while the application menu that runs the exact same command opens the stock version. How can I get the application menu entry to run the Flatpak version?

lol, nevermind…I figured it out. Here’s the solution in case anyone runs into this issue in the future. I changed the command in the application menu entry to /usr/bin/flatpak and command-line arguments to run --branch=stable --arch=x86_64 --command=firefox --file-forwarding org.mozilla.firefox @@u %u @@. Now it opens the Flatpak version.