How to enable confirmation dialog when closing konsole if a program is running in the session?

By default, konsole does pop up a confirmation dialog, but I accidentally set “Don’t show again”. I don’t know how to change it back. I can’t find any option about this in konsole settings

Thank you so much.

Open Konsole’s Settings window and click this button:

Thanks you,best regards! I found that it was because konsole translated into my language that there was a problem with expression, so I didn’t find this.

You’re welcome. If the text wasn’t comprehensible in your native language, it sounds like like it’s been badly translated. I’d encourage you to open a bug report about it at Log in to KDE Bugtracking System.