How to enable virtual keyboard included in KDE?


Using Debian testing, I can not find how to enable virtual keyboard.
I installed package qtvirtualkeyboard-plugin and it works with SDDM, but not within KDE.

When I go to KDE preferences, there is something strange:

  • If running with Wayland, there is a “Input Devices → Virtual Keyboard” section, but “None” is the only choice.
  • If running with X11, there is no “Virtual Keyboard” section inside “Input Devices”.

Do I need to install a specific package? Or should I configure something?


This is non-ideal right now so I’ll try to help. You need two things:

  1. Install maliit-keyboard
  2. Use the Wayland session

In this configuration, the virtual keyboard will appear automatically when you focus a tech field using a touch action.

I’m working on improving this so that the virtual keyboard can be manually opened on X11, or on Wayland without a touchscreen. See applets/manage-inputmethod: make it all about the virtual keyboard (!2780) · Merge requests · Plasma / Plasma Workspace · GitLab.


Thanks for the clarification! I will wait patiently, for now there are other virtual keyboard on X11 that suit my needs.

1 Like

No need to wait, there is “matchbox” and “xvkbd”. They both work under X.

There is also “CoreKeyboard” on flathub and it resembles Android’s, also works under X but is buggy: suggestions don’t show (author claims they should) and it gets stuck on-screen - doesn’t want to close (there is a button on it to do so), so since I’m using a hybrid laptop I had to unfold my physical keyboard and press Escape, otherwise CoreKeyboard would stay stuck on the screen :confused:

BTW, Wayland is much worse at handling touch. Right now I’m on Debian (for this laptop with a touch screen) and X is by default, I installed and switched to a Wayland session and most touch actions didn’t work, the virtual keyboards weren’t working. So X is much better for touch as far as I can tell…

There is no “Wayland”, if our touch sucks more than likely it’s a toolkit or a KWin issue :slight_smile:

Debian sounds sketchy, do you know what version of KDE your distribution has? It’s probably months, or years out of date.

I’m on Debian 11.7.0 that I just downloaded and did a fresh install. According to KDE’s System Information, I’m on Plasma 5.20.5, Framework 5.78.0, Qt 5.15.2, kernel 5.10.0-23-amd64.

And also I forgot to say that on Debian there is no “maliit-keyboard” - and I have the contrib and non-free repos enabled.

5.20.5 was released on 5 January 2021 so I would say its a bit outdated :smiley:

Yeah, if you’re using Plasma (and a system) that old it’s almost certainly better just to stick to X11 :stuck_out_tongue:


Could you give the cmd for installing xvkbd?