How to make google-chrome default?

It is the default in KDE neon settings.

In its own settings, it - Google Chrome could not determine or set the default browser.

From third-party applications, the link opens FireFox.

The purpose shows that the system generally only has FireFox and there is NOTHING to configure :slight_smile:

How to make google-chrome default?

I don’t know what you are referring to.

systemsettings > default application, should allow to set the default browser.

1 Like

this is true, but the browser itself reports that it was unable to identify and install itself by default, in the settings it is by default, but third-party applications open links in Fire Fox

Google Chrome could not determine or set the default browser

There is only one alternative in the x-www-browser link group (providing /usr/bin/x-www-browser): /usr/bin/firefox
There is nothing to configure.

Thank you for the details, we always need details to make informed answers :wink:

Well update-alternatives is a debian specific way to set default.
KDE plasma and Apps follows the XDG specification Association between MIME types and applications

I bet you can add an alternative yourself for chrome for update-alternatives for x-www-browser through some configuration.

Still the application and/or your distro are not compliant with this specifications and they should be fixed (you should have the same issue in GNOME or other DE that complies with XDG specification.
We could workaround this in plasma, but I’d rather not.

Chrome should be able to set itself but it seems it does not support well Plasma, as on my system chromium thinks its default when it is not.

2 Likes

Maybe the issue is that chrome is installed from flatpak and it’s worth installing the official version from google or will it be the same, don’t know?

By the way, I’m working with PhpStorm and there is a setting - open in the browser by default, storm opens in google-chrome.

reinstallation to the official version of the deb package from Google solved the problem: - Google Chrome is used as the default browser

thank you for your attention

By the way, the Plasma Integration extension works in the official version of Google Chrome, but it does not work in the Flatpak version of Google Chrome and in FireFox.

Yes that would be an explanation.
Flatpack apps can’t modify user’s workspace settings by design.

1 Like

This is expected too.
Flatpack is about process isolation, plasma-browser-extension needs direct communication. It could support flatpack with some efforts.

Mentioning that chrome was installed as a flatpack would have saved us a lot of time.

2 Likes

“systemsettings > default application”

works with every browser I tried from flatpak in my Neon VM so it should be some missing package or misconfiguration or the “hardware probe” program.