How to make the bars in a bar chart type widget even smaller?

In editor mode I minimized the widgets as soon as the system allowed (removed unnecessary lettering, changed widget width), but the bars in the left widget are huge, although I wouldn’t mind making them even smaller in the right one.

The left widget shows the occupied memory and swap memory
The right one shows the load of each core.

How can I make the bars even smaller?


Operating System: Kubuntu 22.04
KDE Plasma Version: 5.24.7

the bars auto size (width) based on how many sensors you have on the list

as you can see from this core temp monitor that i’ve pulled out there are 8 bars, but the monitor below it on the panel only had 4 sensors so the bars are wider

if you place the monitor in a panel you can use the panel width to shrink the monitor even further than you can when it is placed on the desktop, then if you want a more detailed view, you can activated it from the panel and get the full size view, as you can see.


I want to have narrow stripes on my desktop. You have on the panel with about 1 pixel wide, but I want on the desktop. I want to make the widget look compact. Maybe some configs can be tweaked?

you can try playing with the .qml… run this

kpackagetool5 --install /usr/share/plasma/plasmoids/org.kde.plasma.systemmonitor

it will make a copy in your ~/.local directory that overides the system defaults

there you can edit the

main.qml file

and try changing some things in there to see what effect they might have

this section looks promising:

    Plasmoid.switchWidth: Plasmoid.formFactor === PlasmaCore.Types.Planar
        ? -1
        : (Plasmoid.fullRepresentationItem ? Plasmoid.fullRepresentationItem.Layout.minimumWidth : PlasmaCore.Units.gridUnit * 8)
    Plasmoid.switchHeight: Plasmoid.formFactor === PlasmaCore.Types.Planar
        ? -1
        : (Plasmoid.fullRepresentationItem ? Plasmoid.fullRepresentationItem.Layout.minimumHeight : PlasmaCore.Units.gridUnit * 12)

see what happens if you make those values smaller

if you mung it up, just delete the folder in your .local and it will revert to the standard behavior.

oh, and you will need to logout and log back in again to see the changes made to the .qml

1 Like

you mean like this?


i changed this line

    Plasmoid.fullRepresentation: CompactRepresentation {

i also changed the values in the earlier part to both be “1”, but i’m not sure that matters.

1 Like

Unfortunately for some reason the settings won’t override. I even rebooted my computer, but even the plugin version didn’t change. Do you know how to fix this?

This started to work, but it’s all a bit off the mark. It seems I have to write my own interface like: plasmoid.nativeInterface.faceController.compactRepresentation

I did it!!!

I put the code in brackets:

Plasmoid.fullRepresentation: FullRepresentation {
    Layout.minimumWidth: 1
    //Layout.minimumHeight: 1

Materials on the topic: