How to prevent DrKonqi automatically rejecting debuginfo package download?

I have to manually do so usually.

This GDB supports auto-downloading debuginfo from the following URLs:

Enable debuginfod for this session? (y or [n]) [answered N; input not from terminal]

Debuginfod has been disabled.

To make this setting permanent, add set debuginfod enabled off to .gdbinit.

This time, it cetainly did provide the option to install the debug symbols, but why make me do so after the log has been generated rather than beforehand? It seems redundant to duplicate the work twice.


but note from 474117 – Unable to report crashes via DrKonqi. that

Twice, 474116 – Unable to generate trace for Spectacle. didn’t affect my report of 474115 – Spectacle crashes when invoked when not invoked with key combination..

Installing the package manually may have helped. The occasional successful attempt at a trace certainly occurred after doing so.