How to restore the 'pdf' (thumbnail) icon and other icons to their original appearance?

Hello Support Team,

Distro: Q4OS 5.2 Aquarius
OS: Debian GNU/Linux 12
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8

System Settings:-
Global Theme: Q4OS Debonaire;
Application Style: Breeze
Plasma Style: Debonaire V2
Colors: Debonaire
Window Decoration: Breeze
Fonts: Default (not changed)
Icons: Waterleaf

The uploaded icons display represent both the original view and the current view.
Screenshot_original & current pdf icons

Because of upload limitations I was not able to embed the LibreOffice Calc icons which view similar differences to the shown pdf icons to which I would like to change the appearance also.

According to Synaptic Package Manager the kdegraphics-thumbnailers package is installed.

My effort restoring them was unsuccessful and kindly request assistance on returning the calc & pdf icons to their original view, i.e. ‘icons1’. Thanks.

There are (at least) two ways how to configure your icons:

  • to configure your complete icon set:
    System Settings → Appearance → Icons

  • to configure icon based on File Association:
    System Settings → Applications → File Association → Select the Application (pdf for example) → Click on the Icon → Select a new one

Hope that helps!

Thanks for responding.

With all due respect, the two posted configuration options did not fix the issue.

I tried all icons in System Settings viz - Adwaita, Breeze, Breeze Dark, Oxygen, Reversal, Waterleaf, We10X and Win11. I logged out/in after each icon change but the desired change did not happen. I currently use the Breeze Dark icons.

The Known Types in File Association already showed the desired pdf icon as in File type application/pdf. In the General tab I clicked onto the pdf icon which opened Select Icon window

  • the Mimetypes panel showed the ‘application-pdf’. I clicked it anyway for good measure alas no change of appearance of my pdf files.

In Desktop Folder Settings-Plasma the Filter type application/pdf was unchecked. I checked it but didn’t make any difference - I left it unchecked.

I also tried several Global Themes and checked the Desktop and window layout on each theme but the issue persists. I currently use the Debian Breeze theme.

I’m sorry to be the bearer of cheerless news, but since you hinted that ‘there’s more than one way to skin a cat’, I would be most grateful for any other configuration options. Thanks.

Do you remember what you were doing or any settings changed when the icons first changed?

I wonder if perhaps it’s the file preview option turned on in Dolphin. This is under the View menu I believe. When on, it will show preview thumbnails instead of icons for certain file types.

1 Like

Hi caleb,

Wow, your post is very enlightening.

You see, as far as I can remember, I always have Dolphin configured to Show Previews as I prefer preview images of video files and if I recall correctly, the pdf and libreoffice icons always showed in their ‘original’ appearance.

Be that as it may, in the Preview tab in Dolphin I unchecked Office Documents and PostScript, PDF and DVI Files. This action ensures that the pdf and libreoffice icons show in their original appearance.

I suspect that previous distro upgrades changed the Dolphin preview configurations.

Thanks for pointing me in the right direction - I am going to check the Solution check-box.