How to set SSID/Password for Hotspot in NetworkManager?

I see in the LiveCD for 23.04 now there’s a Hotspot button in NetworkManager, but I’ve been unsuccessful in figuring out how to set the SSID or Password for the Hotspot it sets.

Would someone be able to enlighten me as to how to configure this network?

Thanks in advance!

In order to create a hotspot, you need to open the networks panel and click the “settings” button (image), then in the “Connections” settings that opens, click “+” and select “Wi-Fi Shared” and “Create”.

In the dialog that opens you can set your SSID and security as you wish.

I’m assuming that the “Hotspot” button you see in the Kubuntu live environment is for a shared Wi-Fi network that was already created as a demonstration, so it has some SSID and security (or none) pre-configured. You should be able to click the “settings” button to go into “Connections” settings dialog, select the hostpot network and review and change its settings.

guss77, this is not working for me. In both cases with the Live environment & with it installed it doesn’t matter whether there’s a connection created as you’ve described, in both cases pressing the ‘Hotspot’ button in the network icon dialog creates its own named hotspot in the network list. In the live environment it’s called kubuntu-hotspot & in the installed environment it’s username-hotspot. The SSIDs are the same name & the networks are open, unsecured.

If you open the network settings click the configure option in the bottom of the connections list there is settings to change the name and password. Aftet it can be toggled by the hotspot toggle in the networking tab. I found it only changed after a reboot and had problems getting devices to connect with a password so i just made it a hidden network and connect by my ssid. Maybe you will have better luck then me

Now it asks me to enter the psk at login as if I’m connecting to it, just to reactivate the hotspot after a reboot. Entering it ends in a timeout & failure of some sort I didn’t bother to screenshot.

To make matters worse, it’s not a connection I can simply delete from the list & reset, so unless someone has a better idea I’ll reinstall again.

Apologies, but I didn’t actually notice that button :sweat_smile: I’ve had my custom set hotspot (as I explained above) and didn’t use the “magic created” hotspot and didn’t notice there’s a button for that. Selective blindness, I guess.

The “Hotspot” button does creates an open network called USERNAME-hotspot (in a Kubuntu live session, the user is named “kubuntu”, so that tracks). When you press that button again (to “release” it), it deletes the network connection entry that it initially created - if you didn’t modify it. If you did modify the connection, for example - by setting a password, releasing the “Hotspot” button will not delete the hotspot network connection entry, but it will also not reuse it if you press the “Hotspot” button again - it will create a new network connection named the same way (somewhat confusing, but its better than calling it “username-hostpot (2)”).

This process is meant for ad-hoc network sharing where at one point you just want a one-off “just click this and be done with it” and you mean to turn it off as soon as you don’t need it and not even remember that it was a thing.

But - if you do want more customized configuration for the “Hotspot” button’s auto-created auto-deleted network, there’s a way to do it: Go into the network connection settings (through System Settings or by pressing the “settings” button in the network list widget/menu), then at the bottom of the dialog there’s another “settings” button:


If you click it, you get an oversized dialog to configure the name of your hotspot and its password (I cut out the huge empty bottom part :stuck_out_tongue_closed_eyes: ).


If you set the password, it sets up a WPA2-Personal secure network (with the password restrictions of WEP, so that’s weird :person_shrugging: ). I needed to log out and log back in to get this setting to actually apply, so mind that.

I’ve tested this whole process and for me it works fine - clicking the “Hotspot” button starts the network and my phone immediately connects, and clicking it again to “release” it deletes the network connection.

I tried that one as part of my troubleshooting process earlier, had no luck. Seems the button is kindof sketchy as of now. The only way I found to restore it after my recent issue was to reinstall the OS, so I’m a bit hesitant to be trying anything new with it anymore.

Ideally I’d like to find where the config file is that defines what that invisible network that appears from the button will use for its SSID & PSK values.

Thank you nonetheless for your reply.

Generally, reinstalling the OS should never be the solution for user configuration issues - maybe a large scale filesystem corruption or getting on the wrong side of packaging conflict warrants such a reaction. The big hammer for user configuration issues is removing the user’s .config and .local directories (the sledgehammer is maybe removing the user account completely and recreating it).

The configuration file for the network connection management is ~/.config/plasma-nm and it contains all the settings for the configuration dialog I showed before, in addition to the “airplane mode” status. All the actual network connections are in the systemd Network Manager database and it’s accessed using D-Bus.

cdb@ConfidenceTanker:~$ less ~/.config/plasma-nm
/home/cdb/.config/plasma-nm: No such file or directory

I don’t want to get into poking around with DBus stuff. I think I’ll just leave it all alone until it matures enough to be usable.

If you don’t have that file, it means that everything is in the default state - pressing the hotspot button will create an open network.

As far as I can tell - this feature is more than usable: it’s mature and stable.

I’m still not sure what issue you are experiencing, but if you think it’s not operating properly - the best way to have a correctly working software is to report issues to the developers.