How to show desktop notifications (produced by one AppImage) above full screen MPV player?

KDE Plasma 5.20.5
Debian 11 (Stable) 5.10.0-25-amd64
mpv --version → mpv 0.32.0

Hello, a messenger application in form of an AppImage is producing desktop notifications which are not displayed when i have an MPV player in a Full screen mode. When MPV is maximized, it is shown.

Please what to do exactly, steps in order to show this single app (AppImage), or all AppImage notifications even MPV is in Full screen mode? If not possible, then to set notifications on the top for all apps and then somehow toggle this setting when needed. ? Thank you

Are you running Wayland? (See in Info Center)

It’s not an issue of MPV. Its all windows under kwin_wayaland - a full screen window, even if not set to “Keep above other windows” will always hide notifications (plasmashell surfaces on the “notification layer”) even when those are set to “Keep above other windows”.

I haven’t checked (not time ATM) if there’s already an open issue ticket for this, but one should probably should be created if it does not exist.

No Wayland… I am unsure if bug exist, I am not right one to submit it properly as i am layman and do not understand workings.
Any workarounds please?

Apparently there’s a configuration option for that (I didn’t remember):

(also - you can post images in the forum - it is very convenient)

It is not there in my case… ::

When I was searching for the option name, I have found only:


Any idea what is wrong/how to make it appear in:
KDE Plasma 5.20.5
Debian 11 (Stable) 5.10.0-25-amd64
mpv --version → mpv 0.32.0

or I assume it modifies certain file, so maybe manually inserting an option in it

That is a new feature from Plasma 5.22 - not just the configuration, even the behaviour.

You’d need to update to Debian 12 to get it.