How to turn off KDE connect's persistent notification on Android?

First of all thank you to the devs and the community for putting out such a great product, I’m a new user who’s really enjoying KDE and KDE connect.

I was wondering if someone here could help with KDE connect notifications.

My issue is that there’s a persistent notification on my phone (Android 14) saying “Connected to: $hostname” or “Not connect to any device”. I would like to disable this notification if possible.

Things I’ve tried:

  • Swiping the notification left to dismiss it. This works for a short while, but the notification quickly reappears, e.g. after locking my screen
  • Disabling the notification. In the app settings there is an option for “Persistent notification: Tap to enable/disable in Notification settings”. This takes me to the Android settings/App notifications/KDE connect menu, where the only option I have is the to disable notifications completely or not. I don’t want to disable all KDE connect notifications, just the persistent one.

I’ve done a bunch of web search to try to find a way, here’s what I found.

  • Same question, asked 5 years ago, solution doesn’t seem to work anymore
    www_reddit_com/r/kde/comments/b3phtv/any_way_to_disable_kde_connect_notification_on/
  • Same question, asked 3 months ago, same solution is suggested. OP seems super confused. www_reddit_com/r/Pixel6/comments/1amt0ge/how_am_i_able_to_remove_persistent_notifications/
  • Same question, asked 5 years ago. Accepted answer suggests a 3rd party app to suppress the notification. Also suggestions to just disable the persistent indicator from the app, see above.
    android_stackexchange_com/questions/203822/how-to-remove-kde-connect-app-icon-from-notification-bar
  • It looks like Android 14 changed the way persistent notifications work and maybe that’s why I can’t disable them like older answer suggest? developer_android_com/about/versions/14/behavior-changes-all#non-dismissable-notifications
  • Same question from 6 years ago (were those the glory days of kde connect??) in the form of a bug report, necrobumped by someone last year bugs_kde_org/show_bug.cgi?id=401028
  • This person last year seems to be having the opposite problem: discuss_kde_org/t/kde-connect-persistent-notification-on-android-disappears-quickly/2283

I’d appreciate any pointers, thank you!

if you untoggle the notification in settings, then you lose the notification screen access to events in KDE connect.

for instance when i send a file from my desktop to to my phone by dragging a file to the kde connect icon in the system tray, the file is copied and i see on my phone that an incoming file is being downloaded but no notification shows up to send me to the file… instead i have to find the downloads folder on my phone and open the file there.

pick your least inconvenient option, i guess.

On some Android devices, there is a setting that allows you to deny specifically permanent/persistent notifications from apps, but as with a lot of Android features, this depends on the manufacturer.

It may be beneficial to open a feature request in KDE Connect to specifically disable this.

No, modern Android allows to toggle different types of notifications. You can disable the permanent one and still get others.

1 Like

I am on Android 14 (Pixel 7), and have no trouble disabling the persistent indicator. I make heavy use of clipboard sharing, so it was a useful if bulky thing for me in previous Android versions.

14 allows me a customizable pull-down and I put one for clipboard sharing there. Then, I just long-pressed the persistent notification to bring up some options:

and either from there, or the app’s info page I get the full set of notification options

My app version is 1.30.1

I wonder if your phone has a skinned or otherwise modded version of Android? Maybe they have hidden some things, or have them in an odd place?

2 Likes

ok, i found it under the hamburger menu inside kde, then under persistent notifications, and then under notification categories at the bottom of that screen.

drilling deep.

Thanks everyone for the replies and @claydoh for the screenshots that helped diagnose my problem!

The issue was that notification categories were disabled across all apps by default. I was able to enable them under Settings/Notifications/Advanced settings/Manage notification categories for each app.

1 Like