How to turn off one click maximize

I often have multiple browser windows open at once. When I click the top bar to rearrange the windows, sometimes it will maximize the browser window.

It appears this will always happen if I double click the top bar, which is fine. However, sometimes it will happen when I only click the top bar once, which is highly annoying. How to turn off/fix this?

KDE Plasma 5.27.7

Do you mean Tabs or really multiple browser windows?

What I think is happening here: While trying to rearrange the tabs you move them not only horizontally but also vertically. Which creates a new fullscreen browser window (atleast for me on Firefox).

What browser are you using?

Thank you for your reply.
I use multiple browser windows, not tabs. I use a combination of chrome and firefox. It seems to happen randomly, but I’ll try to pay closer attention next time it happens.

Could be also a slowly dying mouse that sometimes double clicks.

Or maybe, when you rearrange the window you accidentally push it to the top screen edge, which also maximizes the window?

A possible workaround: use META+LEFT CLICK to move windows around.

1 Like

That would be my guess.

If so, until you get a new mouse, you can turn off double-click-to-maximize in System Settings > Window Management > Window Behavior > Titlebar Actions tab > Double-click > [do nothing]

But really, you should get a new mouse. :slight_smile: They’re not expensive, and a dying mouse will cause five billion other problems on the system that can’t be easily worked around in software.

1 Like

Thank you for the reply. It’s a fairly new microsoft wireless desktop mouse, only a couple weeks old. I know it could still be defective, but I don’t think that’s the case. I will try turning off the double click to maximize setting, thanks again.

Edit: I’m also experiencing some weird issue that I can’t pinpoint either. Where somehow sliding the mouse a certain way, somehow triggers the zoom out overview setting, where I’m looking at all my active browser windows. It’s just a regular two button mouse, where you can also click down on the scroll wheel. So I guess I’m saying, I have more to learn about my mouse and the things it does with kde. I still don’t even know what “meta” is :joy:

Does this happen if you push your mouse to the top left corner? This is likely a “feature”. Check your Screen Edges setting.

Meta is the Windows Key on your keyboard.

1 Like

“Does this happen if you push your mouse to the top left corner?”
Ahh, yes that is very likely what is happening and causing it, thanks! Also thank you for letting me know the windows key = meta

2 Likes

Oh, that’s a can of worms.

Long story short, Qt and KDE refer to the windows key as Meta for historical reasons. Other software may refer to it as Super. Emacs, bash and other software may instead refer to the Alt key when talking about Meta.

It’s utter chaos all around! Time to run in circles screaming with our hands up!

For the historical context, see Super key (keyboard button) - Wikipedia

2 Likes

… and on Macs you would know it as “Apple” key or “⌘” key or “cmd” (command) key.

1 Like