I cannot download kde connect for macos

Basically, whenever I access https://binary-factory.kde.org/view/MacOS/job/kdeconnect-kde_Nightly_macos/, nothing shows up.

Any help is appreciated.

I tried looking for an installable package/binary but unable to find one for macos.

Com’ on… really??? Broken links for Mac users???

It is reported here too 481897 – Kate MacOS link is broken

It has already been communicated already that Binary Factory is to be decommissioned and replaced by GitLab CI.

That part of the transition alongside the QT6 integration work looks like it is still ongoing.

Look for the craft_macos* named Jobs - which are failing.

And here is the overall pipeline - Pipeline · Network / KDE Connect · GitLab

It is interesting to see this comment on Binary-factory.kde.org down - #11 by jlskuz

For the download of nightly binary artefacts an easier to use replacement will go Live in the next days.

Nightly binary artefacts for KDE connect are available on now. Please close this thread if that resolves your problem.


@jlskuz I tried installing it from Index of /ci-builds/network/kdeconnect-kde/master/macos-arm64

but got

I just saw a new build, so providing an update here.

After installing kdeconnect-kde-master-3656-macos-clang-arm64.dmg and now I’m getting

The first issue (“damaged”) was an issue with signing the app which I fix with the version you already noticed.

However this version contains another issue where the configure dialog could not be shown correctly. This is also fixed now.

The “Apple can’t check app for malicious software” message is not new, it was the same with Binary Factory already. I just wrote instructions on how to open the app, please read them: Mac - KDE Community Wiki

If there are further issues with KDE Connect itself after it started, please note that I am not KDE Connect developer. You may want to open a bug report on https://bugs.kde.org in this case

Thank you for providing the information but after following your provided steps on kde community wiki (cannot reshare the links as links are not allowed ), I got this

So, for something like this error, does this need to be reported at kde bugs?

Which build is this? This is the issue I was mentioning:

However this version contains another issue where the configure dialog could not be shown correctly. This is also fixed now.

Please use build 3658 or newer. Does that fix it?

Please note, that the CDN might need a moment to update as it is cached on servers around the world.

1 Like

@jlskuz wow, just installed the 3658 and it worked, beautiful, thanks a ton for your help.


  • is the link on main kde connect download page still points to binary factory.
  • what is the process of updating it? manually check the download page and manually update it?

Happy to hear that!

For the website: I saw that too and created

Waiting for someone to merge it…

1 Like

Super good, thanks a lot again @jlskuz :pray:

@jlskuz is there a possible way to make it auto-update on the system?

No, unfortunately not.