I can't fix CAps LOck delay in KDE NEon

IN every distro i tested - i always had a solution to fix CAps LOck DElay. KDE NEon for some reason doesn’t work with any of those fix so i guess there are nothing i could do?

what do you mean with caps lock delay?

I SHowed It on NAme

ANyone? HElp?

Are you on Wayland or X11?

How i should know that? I have wayland and X11

kinfo can tell which one you’re on.

Wayland (trash symbols to allow post me it)

You can try this solution that I have slightly modified from https://old.reddit.com/r/archlinux/comments/qlxh4p/any_way_to_fix_caps_delay_on_wayland/hj7s0td/

Create the following files:

hidden partial modifier_keys
xkb_symbols "caps_lock_instant" {
	key <CAPS> {
		symbols[Group1] = [ Caps_Lock, Caps_Lock ],
		actions[Group1] = [ LockMods(modifiers=Lock),
			LockMods(modifiers=Shift+Lock,affect=unlock) ]


! option                  = symbols
  custom:caps_lock_instant = +custom(caps_lock_instant)

! include %S/evdev


Enable “Configure keyboard options” under Keyboard > Advanced

and then open ~/.config/kxkbrc and set Options to custom:caps_lock_instant to enable the custom rule.

The only difference in my method to the one linked above is that I create a new option instead of replacing an existing one, but since custom xkb options don’t show up in system settings, you’ll have to modify kxkbrc manually to enable the configuration.

You can get an explanation on what exactly the configuration does in the linked reddit comment.

1 Like