iBus issue with Wayland

Hey when I login to a Wayland session, I get an iBus notification like this.

Please unset QT_IM_MODULE and GTK_IM_MODULE environment variables and ‘ibus-daemon --panel disable’ should be executed as a child process of ibus-ui-gtk3 component.

I am kinda new to KDE Plasma and Linux altogether, so would be nice if you guys could help me debug the issue.

4 Likes

I have the same message, after upgrading kubuntu from 23.04 to 23.10 and cannot find how to remove. Possibly to do with the ‘ibus’ virtual keyboard component?

I’ll add a note that I was having this issue with Kali Linux (based on debian-testing).

I have since moved to Kubuntu and it works fine even after a successful upgrade from 23.04 to 23.10.

I’ll add that I just installed a fresh Debian testing and I also cant seem to find any resources on how to make the recommended changes. if y’all come across something give a shout.

I tried some of following

Reinstal: ibus-gtk, ibus-gtk3 and ibus-gtk4:
sudo apt install --reinstall ibus-gtk3

Disabled Virtual Keyboard in KDE settings
And set KDE desktop session to “Start with an empty session”

Restarting ibus-daemon provides additional info
ibus-daemon -r
and
ibus-daemon --help

It seems like the suggested instruction is not functioning correctly: KDE setting: " “Input Devices” → “Virtual Keyboard” section and select “IBus Wayland” icon and click “Apply” button to configure IBus in Wayland…
There is an additonal instructions for other desktop sessions: to unset “QT_IM_MODULE and GTK_IM_MODULE” - but where / how? - I read how to set an environment variable, but not how to ‘unset’ (Perhaps removing from where it is set - but where?)

AFAICT, QT_IM_MODULE is set by the package im-config.
I didn’t investigate very deeply, but removing the package (apt remove im-config), followed by a reboot I managed to get rid of the annoying pop up.

3 Likes

Just a suggestion:

Go to /etc/environment.d
Create a file called ibus-custom.conf

Add these two lines:

unset GTK_IM_MODULE
unset QT_IM_MODULE

Now these enviornment variables should be unset every time the OS boots up.

If that doesn’t work you could try adding these lines to /etc/bash.bashrc file and start a bash shell on startup immediately.
Make sure to backup those files so you could easily restore them if anything goes wrong.

2 Likes

I followed this suggestion and it works perfectly. The im-config package is not pinned by any other KDE package.

1 Like

I don’t think environment.d works like that. It’s just a config file. You can’t use shell commands like unset.

I had the same problem on my Debian testing system since I installed Zoom (with a dependency to the ibus package).
After removing the im-config package, everything works as a charm here too!
(and some more people got the same problem after installing Zoom as well)

Thank you, apt remove im-config fixed it for me also.

Removing im-config (apt purge im-config) has a side effect: the “TAB” key no longer works as expected in GTK appication: it does not move from input field to other input field. For example when I compose a new e-mail in thunderbird, I cannot autocomplete or switch out the To field of the new e-mail.
Other solutions ?

1 Like

Thanks for the help [sudo apt remove im-config] worked great.