If I use any video effect it doesn't play properly

I use kdenlive on Windows 10. I work in MXF format. If I use any video effect it doesn’t play properly. Can anyone help me in this regard?

MXF is a container without a consistent standard and broadcasters therefore issue guidelines on how program contributions must be designed in MFX.

For trial change the container, for example use Matroska (mkv).

It is possible that your computer is overloaded when effects are added, which have to be generated in real time.
Please try the following settings:
Monitor > Preview Resolution > something different than Full Resolution (1:1).
Please report if the playback improves.

Kdenlive does not (yet) use the GPU for preview playback. Lots of effects or complex ones together with UHD video sources put an enormous load on the CPU and smooth playback is not possible anymore. Like @micha suggested lower the playback resolution in the Project Monitor. If that doesn’t help you can define a preview render zone and have that section rendered so that playback is smooth(er). This is described in the Kdenlive documentation.