Import OFX File in KmyMoney ignores transactions

Hello… here is a strange behavior:

I used so far an old 4.8.3 version of KMymoney (4.8.3-3.7) on 2 PCs (both Win 10 / 64b) on the same Kfile. No problem.
I have updated both PCs from version 4.8 to 5.1.3 (5.1.3_3.1.12) . (Uninstall 4.8/reboot/install 5.1)

-Everything works fine on PC1 importing OFX bank account updates files.

-On PC2 when importing my same OFX bank account update, the OFX file is read but “No new transaction has been imported”. No particular alert.

If I re-install version 4.8 on PC2 , OFX import works fine.
Of course, this is on same File and same OFX file.

I decided to upgrade because on PC1 (a laptop) some numbers were not readable (columns width) and this is solved with the new version
I will survive keeping PC2 on version 4.8 … but I worry it could create compatibility issues with PC1…

Hoping you have an idea. Thanks in advance Regards

Are you trying to use the same data file on the two PCs or are you just starting with a copy of the same file on each PC? If you try to import the same OFX file twice, no transactions should be imported the second time, since they have already been imported. I don’t remember if 4.8 would have imported the transactions again, if that was before we started using a bank provided transaction ID to prevent repeat imports of the same data. 4.8 is no longer supported, so it is important to be sure 5.1.x is working correctly for you.

Thanks for the immediate feedback.
I confirm that 5.1.X Version does not allow the import of an already imported set of transactions, which is not the case for the 4.8.x version-OK.

However, my problem remains if I use 5.1.X on the file AFTER deletion of the last imports or on an older (backup) file which has never seen the recent transactions.

I guess the problem may come from a tiny difference between the 2 PCs environments which I have no clue…

Not sure how we can progress any further

You say “does not allow…” as if it is a problem, but what would be the point of re-importing an existing transaction? Especially if it were matched to the existing, identical transaction? If it were not matched, you would have a duplicate.
However, you talk about using the new version after deletion of the last imports. If you delete an imported transaction, it no longer exists in your data file, so if the same transaction were included in a new import, it SHOULD be imported. Are you importing from a downloaded OFX file, or using OFX Direct Connect? If the latter, it is probably not importing “older” transactions because it is only trying to import transactions since the last import. Try editing the account, and it if is mapped to an online account, there will bean “Online settings” tab. Select it, and then select the “Import details” subtab. That will allow you to adjust the start date of the import.
Does this fix your problem?

“Does not allow”… It is a wording problem from my side. I am happy with this and I just wanted to say that I have verified that on the PC1 which works fine with the 5.1.x Version.

I am using downloaded OFX files (not OFX Direct Connect) which I parameter from the previous latest downloaded record date +1. No dates overlap.

To make the story short, I have 2 similar PCs, one works perfectly with 5.1.x version for OFX files imports, the second ignores imports records unless I downgrade it back to version 4.8.x. .

My analysis is that Version 5.1.x version of KMm is fine but there must be missing a bit of set up on my second PC Windows.

Given the functionalities I am using I can live with the 2 PCs on different KMm versions. But I may find some other problems in the future.

After my last reply above I have made a new attempt on a new OFX import file and …
IT WORKED FINE on PC2 with the 5X version!

I have no explanation (except some structural difference on the 2 OFX files from the ban) … but why no problem on PC1 and problem on PC2???

I feel so confused to have created what appears as a non-issue problem and such a loss of time from the people who took a significant time providing detailed and immediate support.

Although I still remain frustrated not understanding what happened, I apologise.

I will then close this topic. Thank you

It’s one of those things I blame on “the phase of the moon, and blue magic dust.” While it would be very interesting to figure out why your second PC did not work correctly the first time you tried it, it is not likely. Don’t worry about the time, it’s worth it because you learned a bit more about how KMyMoney works.
Also, even using OFX files, some banks really do odd things, and for some, the method that KMM uses for identifying duplicate/identical transactions does not work because the bank creates the transaction ID using the time of download, not just data included in the transaction itself. KMM has a setting to use in this case, which causes it to create it’s own transaction ID and not trust the one from the bank. You do not have that problem. It’s also good that you are able to move to 5.1.

As an astronomer I take umbrage at your blaming the phase of the Moon for the quirks of KMyMoney or the banking systems! While the Moon does play tricks on our minds with regard to its apparent size, I assure you it does not interfere with our financial software. I request that we place the blame squarely on the shoulders of blue magic dust. That s$!t is real! :slight_smile: