Installed Krita from terminal through flatpak; Discover doesn't detect it

I tried installing Krita through Discover using the repos first, but when I launched it, it opened, like, 30 instances filling up my panel, and I got a bunch of errors about crashing applications and internal Ubuntu errors. I closed them, and they would reopen. I uninstalled Krita, and they would reopen. Eventually I just shut down my laptop, which thankfully worked (didn’t need a force shutdown or anything).

However, when I went to reinstall, there were two identical flatpak options. Given the absolute nightmare experience Krita+Discover had given me just 5 minutes prior, I didn’t want to click either of them (which should really be fixed; I have no idea why there should ever be two identical install options). So, I went to Flathub, and just used the command. But when I open Discover, it’s still giving me the install option, not “launch.” How can I fix this?

And, furthermore, what in the world could have caused the package version error I experienced?

I think you could increase the chance for a solution, if you provided e.g. the following informations:

  • name and version of your distribution
  • Plasma version
  • X11 or Wayland
  • flatpak version
1 Like

Ah, my bad. Here it is:

Distro: Kubuntu 22.04.3 LTS
Plasma: 5.24.7
Display server: X11
Flatpak version: 1.12.7