Installing Canon LBP3000 printer on Kde Neon

I am using Kde Neon, and I am trying to install a Canon LBP3000 printer that I bought from Japan a number of years ago.
I have downloaded the CAPT drivers from Canon, I have installed the drivers following the instructions in the driver package, and the printer shows up under System settings - Printers.
I have tried printing a test page, and it just did nothing, and shows the status Idle - filter failed.

This is not the first time I tried installing the printer, either.
Moreover, when I turn on the printer, the system detects and installs it as a second printer. However, this second printer does nothing, as well.

I would be grateful for a suggestion for making this work.
Alternatively, I could buy a new printer (laser monochrome) if you could recommend one that is known to work specifically with Kde Neon…

I should mention that while I can type occult incantations in a console and can click on GUI items, I do not really know what I am doing in Linux…


Ugh, this is the worst. Generally this indicates that you’re hitting a driver bug.

I occasionally encounter the same thing with my HP laser printer. When it happens I re-install the driver from scratch and then the printer works again for a while.

Maybe you can try the generic CUPS driver rather than the one specifically from Canon? Often those are more reliably at the cost of not supporting some of the printer’s features.

I have tried just now the Canon iP3300 seriesCUPS+Gutenprint v 5.3.3, and the status is Printing page 2%, and nothing else happens.
The same happens with Canon LBP3360 Cups+ Gutenprint
Trying with Canon LBP 1760 Foomatic/pxlmono gives Waiting for printer to become available.
Trying with the proprietary Canon LBP3100 CAPT (JP) driver gives Waiting for printer to become available.

I did not find a generic driver that has LBP3000 in its name.

I read somewhere in an old topic ( Canon LBP3000 printer problem - stuck at “Sending data to printer” - Fedora Discussion) that replacing the connection usb://Canon/LBP3000?serial=0000B2666IMQ with ccp://localhost:59787 would solve the issue, but in my case it does not. After the change there is no status message, as if the printer does not exist. Restarting the printer after this change makes the system install the printer with the usb connection, as if it were a new printer.

Just to close this topic, I gave up on the Canon printer. I got a hand-me-down HP Laserjet 1022, and this one works with the (generic) Foomatic foo2zjs-z1 driver assigned automatically by the system.