Installing KDE Neon with btrfs-format fails

Hey there,

i’ve been using openSUSE Tumbleweed for a while now and i love, how btrfs and snapper work to create snapshots of the system.

Now i wanted to go back to KDE Neon, but this time with btrfs and snapper.

I installed Neon and everything worked fine. I have

  • efi-partition
  • root-partition in btrfs format
  • separate home partition in ext4
  • swap-partition

After installation i hit restart but everytime i start the pc i get the error “Failed to start snap daemon” and the system wont boot.
I’ve tried to reinstall in standard ext4 and everything works fine.

Tried this on my other PC and got the same error.

Anyone got some advice or idea on how to solve this?
Does anyone use btrfs without problems like this?
(Im a beginner in Linux…)

Greets, Tobias

They still need to fix that btrfs misconfiguration in their Calameres setup.

two ways to deal with this:
From the live session BEFORE starting the install, go to /calamares/desktop/modules/fstab.conf
Edit space_cache to space_cache=v2. Install as normal, using the correct partitioning.

After an install, you can from a live session or recovery mode, edit the /etc/fstab and add space_cache=v2 to the options section for your /@. So it looks something like this: subvol=/@,noatime,space_cache=v2,autodefrag,compress=lzo

Ubuntu’s BTRFS implementation automatically sets up both @ and @/home, so I am not sure if adding a separate /home partition as you have done is an issue or not, but if you have both listed in your fstab, you can comment out or delete that entry, I imagine, and probably remove the @home subvolume.

There is a post or two on this on the old KDE forum, but that is down atm.

1 Like

Thanks a lot for your help! That worked perfectly!

Installed it normally with root on btrfs and separate home on ext4. Right after Installation i didnt restart but edited the fstab as you mentioned from the still running live session.

Also had to add a line to grub so the timer doesnt always stay on 30s. I read that its because grub cant write on btrfs and so it seems like a failed boot everytime which sets a standard 30s timeout for grub (if i understood that correctly…).

Added “GRUB_RECORDFAIL_TIMEOUT=$GRUB_TIMEOUT” to grub and then everything worked as intended.

Thx a lot!

That is a good catch, thanks. I can’t remember what I used to clear that out, but it wasn’t that.