Is it possible to auto hide taskbar only on specific virtual desktop?

Using KDE\plasma…

I know it’s possible to auto hide taskbar but question is, is it possible to auto hide taskbar only on specific virtual desktop?

I have a VM running on another virtual desktop and would like to auto hide host’s taskbar so that only VM’s taskbar is visible.

this would seem more like an Activities feature than a virtual desktop feature.

have you tried setting your VM up in a separate activity?

1 Like

Thank you very much for mentioning activities!, since I’m relatively new to KDE I still haven’t discovered activities.

Problem however is that if I auto hide taskbar in one activity that will hide it in all other activities as well.

Am I doing something wrong or is that expected?
I hide taskbar in edit mode → show more options.

i guess it’s not the case that you can have different panel settings for each activity, i thought you could… just background image and certain desktop settings, i guess.

anyway the auto hide function on my desktop doesn’t work properly anyway, it just flickers every so often.

1 Like

If you run the VM in full-screen mode, it should render above the taskbar

1 Like

That’s a solid solution, unfortunately you have to exit full screen every time you whish to switch virtual desktops.

1 Like

For me this has not happened since 2022. What distro and update mode are you using?

Operating System: Kubuntu 22.04
KDE Plasma Version: 5.27.11
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.3
Kernel Version: 6.5.0-28-generic (64-bit)
Graphics Platform: X11

1 Like

Ok I don’t wade in Ubuntu Land, however kernel 6.5 will be unsupported soon.
Can you roll back with timeshift or snapper to before the flickering panel issue has been happening?
I suppose then this flicker has been introduced by an update with Discover inside a running Plasma session, but it’s just guessing.

i wouldn’t know about the flickering because the other day for this thread was the first time i’ve tried using it… sorry.