Is it possible to disable this "two different clipboards" system?

I select some text in an UXTerm window. Then I go to another window and press Ctrl + V. It pastes something completely different from what I just selected/copied.

So now I press Shift and Home to select the input text to Delete it, and then press the middle mouse button to paste the actual text I had selected. But now it just re-pastes the same stuff that I just “selected”, erasing the text that I actually wanted to paste.

This madness keeps happening constantly. Some programs use Ctrl + C and others use “select text” to mean “copy”, and similarly, some programs use Ctrl + V while others use middle mouse button to paste. This is extremely confusing and annoying, and causes endless problems and anger for me.

I’ve several times tried to talk to Linux people about this problem, but never get any sensible replies. Maybe somebody here can explain why this is the case instead of having a unified, sane, single way of copying and pasting text.

Also, oftentimes, if I close the program from which I copied a text (by either method), it forgets whatever I copied! Why does the clipboard clear just because a window has been closed? Who thought that this was a good design choice?

This is one of the truly “core” parts of using a computer in my world, and the fact that it’s this broken severely cripples me. It was the same thing in XFCE, too, from what I can remember. So maybe it’s not even related to KDE Plasma.

Is there some way to disable this entirely in KDE Plasma (X11) and force Ctrl + V for pasting? I get that sometimes, such as in a terminal, Ctrl + C is already occupied to mean something else, so in that case, I can accept that selecting text means copying, but it needs to otherwise be consistent and reliable and not dependent on the “source program” still being open!

this is mainly for historical reasons … whole story here: ClipboardsWiki

there are mainly two type of selecting (text) / copying (anything): “selections” go into PRIMARY buffer, copies go into the CLIPBOARD.

it’s feature, not a bug! :wink:

sometimes copied things get loast with the application closes, as the content is owned (from what i remember). ownership might be transferred? (not sure with this)

1 Like

There is an option to synchronize between the two system, in the clipboard widget in the systray. It’s not exactly “disable”, however.

I vaguely remembering ticking such a box, before the clipboard disappeared from that systray (I removed all icons I don’t actively use), but clearly, that didn’t do much good… Also, if I search in the menu for “clipboard”, it doesn’t find any such thing.

the clipboard icon vanishes, if there is nothing in (the clipboard)

I hope this helps you, here are some of my settings

I guess the easiest solution would be to use Konsole :running_man:t2:

The “clipboard” icon is for the Plasma clipboard manager previously known as klipper. As far as I know there is currently no way to disable it as it is part of plasma-shell (it used to be a standalone process), and if you can’t see it - it is likely hidden in the system tray and you can open the system tray overflow panel and find it there (you can also open the system tray settings and set it’s icon to always show).

In the clipboard manager configuration, in the general section, there is a checkbox - “selection and clipboard - keep the selection and clipboard the same”.

I don’t check the options for apps etc unless have problems, I think I remember a checkbox for not let clipboard get empty was in there yeah, where did that go to.