Is there a way to disable VRR only on certain games?

Most of my games suck with VRR and always toggling it off from my monitor is quite annoying. So is there a way to configure what games should use VRR?

Running KDE Plasma 5.27.8 on arch linux.

No, at least not yet. As a workaround you can enable or disable VRR from the command line with kscreen-doctor output.1.vrrpolicy.automatic (or never); you can bind that to a keyboard shortcut for example.

What makes the games suck with VRR in the first place though?

1 Like

Thanks :smiley: This is even better!

Maybe my asus monitor was too cheap probably. Some games have constant white flikering when VRR is on (games like dwarffortress and hearts of iron), some games works just fine and some games without any problems.

Another question, is there a way to query current state by script?

E: kscreen-doctor -o prints current information, I can parse current state from that.

You might be able to run that through steams launch options for specific games. Either some %command% shenanigans or with a script you add to the launch options. Its been a while since I’ve done it after switching to flatpak steam but I know its possible.

1 Like

Technically its a problem with the panel and a result of changes in refresh rate actually change display brightness (idk why I just know it does). If the games framerate is more stable you’re less likely to notice. I “think” those games probably have less stable performance which might be why.

1 Like

yeah, it’s down to the physics of how the displays work; with reduced refresh rate, brightness is also reduced, so if a game has lots of fps drops, the brightness constantly fluctuates up and down. It’s not just cheap displays either, it’s generally really bad with VA displays (which is very common in high refresh rate displays, even on high end monitors).

There’s some possibilities of working around this in KWin by restricting how much we allow the refresh rate to change in a given second, but it’s relatively hard to make the scheduler reliable enough to make that work. Some monitors also have that as a built-in workaround; on mine it’s called “VRR control”, so if you have something like that you might want to test that too

1 Like

That made me think, its a bit complicated vs other options but i imagine editing the EDID and limiting the VRR range might also hide the issue too but thats a bit more painful than if your monitor has a workaround or you can just not use VRR if its really bad.

I have no VRR control and EDID files are way too scary for me :smiley: so I just toggle it off for now.