Is there a way to force delete the Tag list on the Dolphin?

Somehow my dolphin only has two tags listed after attaching many to one file, and those two tags seem… permanent, they can’t be renamed (the actual tag, the name on the left panel can be renamed) and can’t be deleted, every time I rename the actual tag and deleting it, it will come back just after a refresh (F5), launching Dolphin from the terminal doesn’t show anything in the process except when opening the tag after being renamed (but not refreshing it) prints kf.kio.workers.tags: "tags:/Test" stat() invalid url, Test here is what the Tag should be renamed to, not the original/previous name. So is there any way to force delete or reset Dolphin’s tag list?

The step I run into this is

  • Select a file
  • Click Add on the tag section on the preview/information panel (the panel on the right side of the dolphin)
  • Add multiple tags in quick succession
  • Notice that (at least in my case) after a while, the Tags section on the left side of the Dolphin shows “All Tags”, “Tags 1”, and “Tags 2” (in my case) but not the other/rest of the tags I added to the previous file.
  • Adjust the previous file’s tag by removing every tag first, close the tag dialog for the file, then click Add again on the file info
  • Notice that (at least in my case) available tags are only the “Tags 1” and “Tags 2”, the previously added tag has gone
  • Add the remaining tags to the file, close the dialog afterwards
  • Click the Edit on the tag section of the file info again (modify the file tag)
  • Remove every tag from the file, close the dialog afterwards
  • Note that (at least in my case) the two tags still remain, even though there’s no file in the whole system that uses that tag
  • Now either try to delete or rename the actual tag (not the Tags section on the left of the dolphin)
  • Refresh (F5) after doing so
  • Note that (at least in my case) the tags are neither got renamed nor deleted

Just in case this is actually a Bug, I already submitted it here

Have you tried using the CLI commands, getfattr and setfattr? I find them clunky and obscure, but setfattr -x user.xdg.tags <filename> should wipe out the “name” dolphin uses for the tags.

Sorry for not explaining things better, what I meant was removing the tag list that Dolphin store, through Baloo as it seems, not the tags that are associated with the file, the attribute interaction with the file is fine and working, it’s the Dolphin and Baloo that seems to be broken, and after trying many things, it seems that using balooctl purge ‘fix’ the issue, but another problem arises that, Dolphin or rather baloo, doesn’t detect any tag changes anymore after this, I still need to check this further.

Ah, baloo. (Rant temptation… taking deep breaths…)

Baloo’s index is opaque, we’re not allowed to see what it’s doing, and we can’t diagnose failures (which manifest in many ways).

Unless you have many terabytes of indexable data (for music and video only the metadata is indexed, a few hundred bytes per file), I suggest recreating the index. In a konsole:

balooctl disable
balooctl purge
balooctl enable

That’s not entirely true, baloo does have some form of diagnosis, check these commands:

balooctl status
balooctl failed
balooctl monitor
balooctl indexSize

They might not be perfect but they at least provide some info.

Edit: mostly typos

1 Like

Thank you. When I was trying do diagnose baloo failures a few years ago, I tried all the available commands at the time. I’m not sure “failed” or “monitor” was there. But then baloo tried to burn a hole (that is, exceed the rated TBW within weeks) in the desktop’s boot SSD by rewriting something continuously, and I haven’t let it run since.