Issue with KDE Plasma 6 Beta 1 + Chromium

I am using KDE Neon ‘unstable’ with ‘wayland’ and have had few issues.

I installed Chromium and it loads but besides an outline bar and the chromium header the screen is empty just showing the desktop wallpaper - empty.

My system info is:

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.90.90
KDE Frameworks Version: 5.247.0
Qt Version: 6.6.1
Kernel Version: 6.2.0-39-generic (64-bit)
Graphics Platform: Wayland
Processors: 16 × Intel® Core™ i7-10700 CPU @ 2.90GHz
Memory: 15.2 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2060/PCIe/SSE2
Manufacturer: Dell Inc.
Product Name: XPS 8940

If I switch to x11, Chromium works fine and I have also installed Chrome and this works fine with Wayland.

What am I missing? Many thanks.

Every other thread mentioning a problem “always” mentions it together with “this happens on wayland and not on X”.

In the end, i do not understand the Linux community’s aggressive push of wayland to replace X11. I mean why is the hurry? There are too many issues to resolve still. It is obviously not ready. Why is the rush?

Calm down, the person is saying it works on x11 to inform that it’s not an app thing, he’s not necessarily comparing wayland to x11.

xwayland will just work.

Try to force to run the app through xwayland and see if that works?

Something like

GDK_PLATFORM=x11 chromium # for Electron and GTK apps, probably Chromium too
# or
QT_QPA_PLATF0RM=xcb chromium #for Qt apps

I did the latter with QGis. You can edit the application desktop entry to fix that, but Chromium should support wayland natively so this is a bug (–>

# something like this
cp /usr/share/applications/chromium.desktop ~/.local/share/applications/chromium.desktop
sed -i 's/Exec=chromium/Exec=QT_QPA_PLATF0RM=xcb chromium/g' ~/.local/share/applications/chromium.desktop

Thanks for the postings.

I started chromium from a konsole window using the command:

    QT_QPA_PLATF0RM=xcb chromium #for Qt apps

and received a long error message ending with:

KMS: DRM_IOCTL_MODE_CREATE_DUMB failed: Permission denied
KMS: DRM_IOCTL_MODE_CREATE_DUMB failed: Permission denied

(chrome:10957): IBUS-WARNING **: 09:44:03.402: Failed to mkdir /home/garry 
/snap/chromium/2713/.config/ibus/bus: Not a directory
Warning: vkCreateInstance: Found no drivers!
Warning: vkCreateInstance failed with VK_ERROR_INCOMPATIBLE_DRIVER
at CheckVkSuccessImpl (../../third_party/dawn/src/dawn/native/vulkan 
at CreateVkInstance (../../third_party/dawn/src/dawn/native/vulkan 

at Initialize (…/…/third_party/dawn/src/dawn/native/vulkan/BackendVk.cpp:379)
at Create (…/…/third_party/dawn/src/dawn/native/vulkan/BackendVk.cpp:301)
at operator() (…/…/third_party/dawn/src/dawn/native/vulkan

If I run ‘inxi -G -c0’ it shows:

Device-1: Intel CometLake-S GT2 [UHD Graphics 630] driver: i915 v: kernel
Device-2: NVIDIA TU106 [GeForce RTX 2060 Rev. A] driver: nvidia  v: 535.129.03
Display: wayland server: v: with: Xwayland v: 22.1.1
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: fbdev,nouveau,vesa gpu: i915,nvidia resolution: 1920x1080
OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2
v: 4.6.0 NVIDIA 535.129.03

Chromium on Fedora works just fine on Wayland only. Same with many Electron apps but not all.

Havent tried it on Plasma 6 though

My original problem with Neon KDE Plasma 6 and Chromium with ‘wayland’ now works. It was resolved by one of the many subsequent updates.