Issues with the Panel in Plasma 6... Windows cannot Cover

Manjaro pushed Plasma 6.0.2 through to testing branch today, and it’s quite a big change. Some things are, indeed, improved.

Most concerning one for me is the regression…

My first symptom was that when launching conky, I have separate instances for a Clock (always on top) and then the date, a network traffic graph, Disk indicators, and a small note telling me the date of the last snapshot, and the last backup - then reporting RTCWake time if set.

Now I found all these windows were fixed ON TOP, not respecting the below setting until I removed the dock window type from the setting.

Is this a deliberate decision?

On to the panel, unfortunately.

Since using Gnome2, I treasured several features in docks/panels.

  1. I want my systray available by default, not autohiding, not covering windows unless I mouse over the panel to focus, and not dodging any window which comes within a 200 pixel range. The panel should not be rendered inoperable by a vertically or horizontally maximised window.

  2. Dodging windows is fine, as long as the panel flips to the front when the mouse arrives at the screen edge.

  3. Windows being able to cover docks is fine, but windows going underneath docks is insane IMHO - having also tested this with GlobalMenu, I am confident that the panel should only come forward when the mouse arrives, and it should not prevent windows from being vertically maximised.

Same here on openSUSE Tumbleweed. I miss “Windows can cover” for things to sometimes have out of view (covered) and at other times visible (windows arranged around panel).

Of course, I could place the widgets on the desktop, right?

No. Try to emulate the window list in Task Manager when it sits in a vertical panel with the Task Manager desktop widget: That is not a nice vertical stack of window titles (w/icons), but a too loooong horizontal bar. Rotate it to get it vertical, and the text rotates with it. Both orientations are not usable. :-((

It’s not such a problem now - I was mostly still facing some issues because I hadn’t fully refreshed my $USER data - but now find that the auto-hide is working perfectly (and was always my preference with docks, until I quit Latte dock when it entered it’s ‘maintenance’ mode and reverting to the Plasma panel).

It’s worth mentioning that Plasma lets you make multiple panels, so it’s feasible to have a SMALL panel to support one or two items which need to be horizontal - top or bottom (like Globalmenu, Clock) and also a vertical panel would work for your task manager/systray.

It’s actually much better now.

Having managed the upgrade to Plasma 6 on Manjaro (Arch) The loss of the panel option to “Allow windows to cover” is an annoyance. The “Dodge Windows” and “Auto-hide” behaviours are no substitute. “Windows go below” has no real use as maximized windows have the window controls hidden.

Allowing windows to cover allows windows to be maximized and the plasma panel bar to appear when the mouse goes to the top edge of the screen. Maybe the design only considers users who use the panel at the screen bottom.

No, the only difference is that - rather than covering the panel, it moves out of the way. I brought this up as an initial knee jerk reaction when I upgraded Manjaro - 2 months ago on Testing.

As with many knee-jerk reactions, it’s more a shock at the change of something I thought was great.

However, you’ll appreciate that you’re wrong in the end… It is tidier and more reliable/fluid, plus it is relying on more easily maintained code, bringing down the workload (reducing the bloat).

It still activates and pops up on top if you mouse to it’s location… and it works well with all 3 of my panels (that’s top and bottom, and I also had one of those on the side for a while).

1 Like