Japanese language support and Firefox

Hello, everyone.
This is about some difficulties I had with Japanese language support and the workarounds I found. My question will then be if it is possible to not use these workarounds, which are annoying.

First, I needed Japanese language support on my system with English keyboard.
A newly installed Kde does not have this. From the settings interface you can only install a Japanese keyboard layout, but not the input method.
I searched the net and found on the Archlinux wiki that you need to sudo apt install fcitx and its modules ficitx-mozc and/or skk, anthy. You then need to use im-config to activate fcitx, then log out and log in again in your session. Then you have to set up your input methods, from the regional settings.
Well, I did all that, and fcitx was not activated. After much headscratching I set fcitx to start in the startup autostart settings.
That done, I can now input Japanese in some programs, such as Thunderbird and LibreOffice.
However, not all is good. In Firefox it is not working. After much searching, it turns out that this was a bug in Firefox, which was supposedly solved starting with FF 101. We are now on ff112, so what is going on? Well, it appears that the version of firefox that comes installed with Kde Neon still has this bug, even after updating and upgrading to the latest version. I installed firefox from Discover, the flatpak version, and this one does not have the bug, I can input Japanese in it, with the kludged fcitx described above. This solved the immediate problem of the input, but it is annoying because the default browser is the one that does not have the correct input, and that is the one that gets called from links from other programs.

In conclusion, things seem to work, more or less, but I wonder if there is a better way to (1) install multiple language support that does not need workarounds, and (2) works in all inputs.
Or, at least, how do I replace the preinstalled firefox with the flatpak one?

So, I’m guessing ( dunno) you’re using a Kubuntu which has FF as a snap installed? In either case, you need to uninstall the halfworking one. After that, you’ll need to create a link in /usr/bin to the executive flatpak ( make sure there isn’t an older firefox file in /usr/bin ). If there should be a firefox.desktop file in /usr/share/applications, you might wanna change the exec path to the flatpak one as well. More than likely you’ll find one in ~/.local/share/applications with the new path. As an example, I don’t use snap on kubuntu. I installed a regular FF which resides in /opt.

Yeah this sounds like it might be a Snap issue, I use Fcitx5 for Japanese IME and I have no trouble inputting into Firefox (Wayland or X11)

I am using KDE Neon, and the FF that comes with it. The location is ~/.local/share/applications. For the flatpak one the location is ~/.local/share/flatpak/exports/share/applications.
Thanks for your instructions, I shall try to follow them. However, I don’t exactly know how to uninstall this bad firefox. I can uninstall the flatpak one from Discovery, but this one does not seem to be there in the list of installed items…

Not a snap issue. Fcitx5 is broken in kde neon. I already reported it a while back, you can check it here. But fcitx should work fine. Did you forget to change the environment variable by any chance? Fcitx - ArchWiki

I do not understand how to set environment variables form the arch wiki, so I did not do it. That may explain many of my difficulties…
However, I did install Fcitx5 from the command line, and it works with the workaround of starting it in autostart.

You are facing the problem most likely because you didn’t set environment variables . Set the envirnment variables, it is very important. All you need to open the file /etc/envirnment and add the following to it, then reboot.


When I last checked fcitx5 didn’t work on qt apps. You can check if you can write Japanese in kate or kwrite.

Apparently I have done that at some point, because the environment file does contain these lines, and I can write Japanese in Kate.
Frankly, I have been struggling with fcitx for some time now, so I no longer know what exactly I did and did not do.
Anyway, thanks for your response.

1 Like