Just cannot get wipes to appear/work!

Ok, I figure this must be ‘me’ because nobody else is reporting this problem but I am hanged if I find a fix to get wipe to work on any resolution other than HD upwards… which I do not use.

I cannot find this reported as a bug but I have ‘put up’ with this for nigh on two years always hoping the next build would solve this.

Can someone please show me what file I need to edit or whatever to resolve this?

The details:

Under Kdenlive under ANY VERSION of Linux (NeptuneOS, Mint and MX-Linux 21 and 23 and I tried it in Manjaro as well at one point) it’s hell’s own job getting lumas/wipes to work.
Under Version 23.x I cannot get wipes to work at all except if I edit as HD video… which I never do. No matter where I put the lumas files (I have saved all my one time downloaded lumas files to a folder due to this problem!) whenever I select a wipe I will only get ‘dissolve.’ No wipes will appear unless the video quality for the edit is HD! NTSC, PAL, CIF which I use… nothing. I am a LOW quality render user here!

I CAN select ‘custom’, go to my folder of collected wipes and the wipes will appear and I can select what I need for that wipe.
But the next wipe on the next cut… and the wipes have gone again. I have to repeat selecting custom on every single wipe! That’s a non-starter.
That’s with the software in the repos, flatpak and appimage!
If I download any new wipes they go into .local/share/kdenlive/lumas/HD. They NEVER go into the required NTSC or PAL folder and are not picked up in any resolution lower than HD. Indeed, such folders such as NTSC or PAL are never created! It’s like Kdenlive is now hardcoded(?) for HD and above video editing.

Using version 21.04.03 as an appimage I have the same problem but I CAN force wipes to work but it’s a crazy process.

First, I have to take my local copy of my wipe files and copy them NOT to .local/share/kdenlive/luma/NTSC but, instead to /usr/share/kdenlive/lumas/<PAL/NTSC, whatever.> I am currently using NeptuneOS 7.5 but will be upgrading to 8.0 when my SSD arrives but tests on MX Linux 23 on other laptops have the same problem.

Then, in kdenlive 21.04 when I select a wipe I will STILL only have ‘dissolve’ but then, wait for this… I can select ‘custom’, find a random luma file, click on it and, the program freezes for a while but then, it comes back and I have ALL my wipes. The software will work from that point onwards and I can edit happily but only for Kdenlive 21.

Versions 22 and 23, I CANNOT get to see my wipe files no matter what I do. Yes, I have tried copying my wipe wipes to .local/share/kdenlive/lumas, creating a NTSC folder (I generally use widescreen NTSC for a mass of reasons… I am not a pro editor here) and .kde/share/kdenlive/lumas


But I cannot find anyone else reporting this so I have always figured it must be me. But it’s driving me crazy now! There is nothing reported in the Kdenlive bug tracker so…

…it must be me but I am lost. I would kind of like to try the latest Kdenlive but without wipes it’s a non starter for me and editing in HD is a bit of a crippler when I have to use a low spec celeron laptop to edit while doing other work! And half my sources are only DVD quality anyway.

Soooo… can anyone help here? Thanks.

I love Kdenlive to bits but this is… bizarre.

I am having the same issue (23.04.3 appimage or installed (kdenlive-stable ppa) on Pop!_OS 22.04) but do not use custom wipes that often so this is not too much of a nuisance. The only difference seems to be that I get the standard wipes like Bi-Linear X without any problems. Custom ones I need to specifically select via Custom... but then they are available.

I strongly suggest you log bug report in bugs.kde.org with as much information about your workflow and the issues you posted here. Thanks!

Could you try the nightly appimage and try to reproduce please?

Thanks for helping out! I always appreciate it when the community steps up.

I have tried the nightly build:

Identical situation. I select ‘wipe’ and only get dissolve. I go to ‘custom’ and my collection of lumas and click on one. ALL my wipes appear. I then try another wipe and… only dissolve is shown again. The wipes are never picked up unless ‘loaded manually’ each and every time UNLESS the project is set for HD.

I presume at this point it is worth filing a bug report? I do not want to do such, obviously, if it is config issue or me being dumb but that does not now seem to be the case here.

Once again, many thanks.

Oh, it might be worth adding that with the nightly build and any release appimage of Kdenlive past 21.x I get the ‘worker KIO’ message that others have reported. I just click and ignore but since both the KIO message AND the wipes issue occur in Kdenlive 22.x onwards and NOT in 21.4 I wonder if there is some weird connection?

I’ve already pointed @mardelle to this post. Stay put to see if he can reproduce it or not.

Great. Again, my thanks.

This is consistent across ANY version of Linux I try Kdenlive on!
I guess everyone except me edits in HD!

Yes, I can confirm the issue. I guess not many people still edit in NTSC. I just fixed a few things for 23.08.0:

  • a list of default wipes will now appear for NTSC
  • you can add luma files to the folder "$HOME/.local/share/kdenlive/lumas/NTSC to make them always appear in the list

And yes, the download dialog always assumes the luma files are HD, this should eventually be fixed but won’t be ready for 23.08.0.

You should at least be able to work now with 23.08.0 by copying your luma files to this folder.

1 Like

Oh great! Thank you. That will do for me!

So I wait for 23.08 which is due the 18th, have I got that right?
I can test a nightly build if that would help.