K3b failing to launch reliably after Plasma 6 MEGARELEASE

Hi, on machine running 64 bit openSUSE Tumbleweed Plasma 6 with X11, K3b fails to launch from menu tray successfully alot of the time.

I have tried export QT_QPA_PLATFORM=offscreen logged out/in and no better.
I have tried export QT_QPA_PLATFORM_PLUGIN_PATH=/usr/lib64/qt6/plugins/k3b_plugins and I believe it does possibly help starting K3b by Konsole as before it would segfault and not begin ever. Was this ok to have tried?

k3b does execute most of the time from Konsole but not every time now. As I type this and attempted to start K3b by menu it did start. This is inconsistent though.

I didn’t see anything recent on here about K3b problems like this so this maybe isolated. How should I proceed with this?

Have you tried launching from the terminal to see if any error messages are generated?

I have this after trying to open with sudo k3b

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: From 6.5.0, xcb-cursor0 or libxcb-cursor0 is needed to load the Qt xcb platform plugin.
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: wayland-egl, wayland, eglfs, linuxfb, minimal, minimalegl, offscreen, vkkhrdisplay, vnc, xcb. **

I have powercycled and iK3b has consistently started from menu and Konsole 4 times each as of now.