Kate and reopening recently opened files

when kate is already open, and i go to File there is Open Recent… which works as expected.

but when kate is not open, and i right click on the Kate launcher in the task bar i also find a list of recently opened files… but they don’t launch kate, they don’t do anything.

what am i missing?

and while we are here, is there some way to have kate remember the size and location of the window so it doesn’t always open in that postage stamp sized window in the center of my main display?

Works for me on Fedora 38 KDE from the alternative (traditional?) menu.
If I pin it to the taskbar, it also works.

But if I add it to the tray, it doesn’t show the recent files.

What distro are you using? Plasma and Kate versions?

this is kubuntu right clicking on the icon in the task manager, and even if i go to kate in the app launcher and right click there, the same thing happens

i can see the list, but i cannot open the file … i t wont even open the app

the only way to load the file is open the app with a blank document and then choose the recent files from the file menu.

re-upping this help request because the issue remains unsolved.

it’s not a bug since i just verified via Kubuntu 22.04 - DistroSea that kate does indeed function as intended on a fresh install

so something i’ve done has broken it and it’s been broken for a while now so any recovery options have rolled off the back of the desk moths ago.

any tips on how to troubleshoot this and/or reinstall just kate so that it works as intended… i don’t care if i lose my kate preferences.

While they appear for you when you right click the Kate launcher, is it possible that the file type of each item is set to open in another application than Kate (e.g. KWrite) and that is why they don’t open?

no the file is only ever opened in kate and when i created a test file in the simulator and saved it, i was able to recall the file from all three places

File>Recent files

right click on the pinned task manager icon and select the “test” document

find kate in the applications menu and right click on the app icon then select “test” document

all three worked in the demo, but only the first one works on my machine even tho the file name appears in every instance.

you know what… i looked at the file properties and its claims to be a MATLAB file (whatever that is).

i created this file in kate, so i’m not sure how it got this mime type or how to change it

could this be causing the issue?

if i click OK here then i’m changing the default program for MATLAB documents and i don’t think i want to do that… i want to change the document to simply be a text document.

how do i do that?


also if i

grep 'text' /etc/mime.types | sort

it does not list matlab as a type

the mime type was the problem

the file had somehow been given the MATLAB type designation

tried cutting and pasting contents into a new file with a different name and it sill gave it that type

so i tired appending a line to the top of the file that was just plain text (no # characters)
and then it saved as a plaintext file

so now it opens in kate from all 3 methods of using the resent files menu.

thanks for putting me onto the path that ultimately fixed it… been driving me nuts.

1 Like

Good to hear that you got it resolved.