KDE 6 Not saving Theme Customizations

Hey recently got KDE 6 and started ricing. But noticed that my changes to plasma theme, window deco, icons, cursor, and splash screen keep resenting to nobara defaults on every start up. The only thing that doesnt reset is the login screen.

Has anyone run into the issue?

Which operating system you use? Is it possible that you use an immutable operating system that doesn’t let you update the config files?

So sorry! I am using Nobara Linux 39 KDE Plasma

Nobara is - to the best of my knowledge - Fedora with tweaks, and you should not have that problem. The only thing that I can think about would be that for some reason the ~/.config files have permissions set so that it is not possible to update the configuration files.

I would try this:

  1. Open Konsole (or another terminal application).
  2. Run sudo chown $UID $HOME -R - it will ask for your password to allow the operation.
  3. Run chmod u+w ~/.config -R

Then try to see if that fixes things.

When i ran " sudo chown $UID $HOME -R" i got the output “cannot access ‘/home/wane/pCloudDrive’: Permission denied”

which makes sense since thats my cloud storage, i tried “chmod u+w ~/.config -R” and then “chmod u+w ~/.config -R” both commands gave no output so i guess they ran fine. but on restart the changes still dont save

Can you share the output of findmnt --target ~/.config ?

I have the same issue on Nobara and if I tried your steps nothing happend.
Terminal did not return anything, so I suggest to continue with the second command after the second one I set my plasma theme up and reboot. Unfortunatly after login it was all the same default as before.
Any other ideas what to try please?

@weathelm can you share the output of the command I posted above?

But if you are also seeing this in Nobara, then this issue is likely a very specific behaviour for Nobara and I would ask on the Nobara discussion places, which seems to be their Discord and possibly r/NobaraLinux.

Well not it saves my selections. So "chmod u+w ~/.config -R” did something. Only problem now is that the background image resets every time now

Are you using the standard “Image” wallpaper plugin, or something else?

one of the command worked, but after doing a fresh install and using kernel 6.8.5 i dont have the issue anymore. but our initial attempts at changing permissions partially worked so that must have been the issue and the update just rectified it

which version of kde plasma are you using ?

There’s a chance this will be fixed with Plasma 6.0.5.