KDE 6 Upgrade Broke Fonts in Wayland

Hi all,

After upgrading to KDE six just after it came out, I’ve sorted out almost all the new bugs with one exception: my fonts (inconsistently) look terrible in certain places.

I’m using KDE 6, Arch Linux, on a thinkpad t480s. As the t480s has a HiDPI monitor, the desktop is set to 150% zoom. I use the wayland session by default.

Interestingly, the font rendering problem goes away completely in the X11 session. I can’t really say why, as the buggy font is present in both native plasma desktop applications/widgets, rather than just electron apps or native X apps being broken.

Edit: (Apologies, it seems I cannot post multiple images. Imgur should suffice hopefully “://imgur.com/a/ltJ1WWL”. There are multiple images posted there, each displaying a broken wayland image, a ‘normal’ X11 image, or my general font settings.)

Edit 2: It seems that even links are disabled. The above link has been edited but will need the “https” added back onto it. I will append one image here.


Note how the fonts on the left are broken, but not on the right.

The custom icon theme has no bearing on the fonts, and font rendering is the same if I disable it.

I noticed today that MELD now sucks on Plasma Wayland, but runs fine on X11.

System Info

Operating System: Manjaro Linux
KDE Plasma Version: 6.0.2
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.2
Kernel Version: 6.8.1-1-MANJARO (64-bit)
Graphics Platform: Wayland
Processors: 12 × AMD Ryzen 5 5600G with Radeon Graphics
Memory: 15.0 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Product Name: B550M Steel Legend

Is this a bug, or is it a remnant of previous configs?

The plot thickens - logging in with a TEST user, I got this:

So this looks like something which I didn’t clean up properly after upgrading.

Sadly, this is not something contained in the Home folder, I tried moving everything out - and the issue remains… but NOT with a TEST user!

Update:
I found some weird things out. Launching Meld from terminal was fine, I entered my ~/.local/share/applications folder and looked at the launcher - deleted that and everything’s fine.

The issue was probably launching with GTK Portal… so there you go, OP - probably take a look at cleaning out more junk from before your upgrade…

A complete throw in the dark here.
Those font “artifacts” looks EXACTLY like trying to run harwdare accelerated GPU without support for it. (for example using hardware acceleration in firefox without having it set up correctly)
Just a wild hunch, take it or leave it. :heart:

what a GTK4 heresy!

Real KDE users use Kompare or Kdiff3 :sunglasses: :+1:

3 Likes

Lolz yes, actually it’s an old launcher - not sure why that affects ‘open with…’.
org.gnome.Meld.desktop

The relevant line, I believe, Exec=env GTK_USE_PORTAL=1 meld %F

Deleted the launcher - now it’s all hunky dory.

This is 479891 – Some text glyphs in QML software are mis-aligned or squished when using a fractional scale factor. It affects fractionally-scaled text. It’s looking like a Qt regression, which KDE contributors are working to fix upstream right now. Hopefully it’s resolved soon.

3 Likes

Oh noo, I was a fake user the whole time without knowing about it!
I will IMMEDIATELY adjust my incorrect way of handling diffs, thank you. xD :heart: :nerd_face: :melting_face:

$ sudo nano /etc/environment

- DIFFPROG=/usr/bin/meld
+ DIFFPROG=/usr/bin/kompare
1 Like

good job, now the more important one, remove the pamac GTK4 attrocity - insult to KDE. :smirk_cat:

Challenge accepted. xD
(or maybe not)

Thanks Nathan, good to know it’s not just me being half-mad lol. I’ll eagerly await work on it in future.

1 Like

Haha I don’t use Pamac much - but it’s good to include Flatpak options alongside AUR and repos…